When deleting a RS icons loose their styles

Hey there,

not directly related, but it seems that this previous mentioned bug also get’s applied to icons:

When deleting a relative style, my icons loose their styles (at least the size and color).
The markup looks like the following. So when deleting on the parent any relative styles, it looses the styles of any icon inside that wrapper.



Hi @Wolfgang,

Sorry to hear you’re experiencing trouble with this.

Unfortunately, I haven’t been able to reproduce this error on my end.

Could you possibly detail if this is happening specifically with a global class relative style?
Do any errors appear in your browser console log?

To investigate this further, I have set up a demo instance.
Please log in with this, and see the Test page.

Feel free to play around with this, and see if the issue is reproducible.

Additionally, it would be very helpful if you could provide a screencast of the issue, so I may try to reproduce it on my end.

Thank you in advance.

Hey @Araminta ,

I didn’t tried your demo instance, but I recorded a screencast on a different installation which produces the same result - i think it’s a very niche bug, thats probably why you were unable to reproduce it - i was unable to reproduce it first too! :wink:

In my record you can see when the bug appears - hopefully that helps!


Hello @Wolfgang,

Thank you very much for taking the time to make a screencast and go through the steps.
I can confirm there is a bug. We should have a fix for this in the next update.

My apologies for the inconvenience.


1 Like

As always, thanks Louis :slight_smile:
One thing: there’s never any inconvenience when using cwicly :heart::sunglasses:

You’ve made my day!
I very much appreciate the time that it takes to report these bugs.

As a side note, I have enabled .mp4 uploads on here if it helps make sharing videos simpler.


Hi @Wolfgang,

Thank you for bringing this to our attention!

This should now be fixed with 1.3.
Kindly let us know if this is the case on your end.

Thank you!

Hey @Araminta ,

yes it seems to be fixed, but I faced (in that second of writing) another Problem related to the global class relative style stuff.

When adding a relative style via the copy/paste function inside a global class where the class is applied to the columns (wrapper) block it seems that the fractions (for the class itself) set inside the grid editor get lost (on all breakpoints), seems somehow related! :wink:


Glad to hear the first issue was fixed!

You never miss a trick @Wolfgang!

This should now be fixed in
I would appreciate if you could let me know if this is the case on your end.

Thank you!