Unable to get Cwicly builder changes to show on frontend

None of the settings within the Cwicly builder are showing up on the frontend of my new WP site. It doesn’t appear to be a caching issue as changes to post content shows up immediately. (I’ve disabled browser cache in Chrome dev tools & disabled my caching plugin).

I can hand code the css in the advanced tab + apply classes in builder and that does show up.

I am using the Cwicly theme with cloud hosting on Hostinger.

Much appreciated to anyone who can help point me in the right direction.

Hi @Jack,

That does sound unusual. Can you provide a bit more information on exactly what settings you are configuring and the difference between what you are expecting to happen and what actually happens, then I’m sure answers will be forthcoming.

Thanks Marius - I went through the steps and this did not resolve my issue.

Here is one example: Trying to get column children to display flex; using Ciwcly to set the parent columns container to display flex, direction and justify…it doesn’t show up on the frontend.
I would attach some images to this post, but because I am new, my account is restricted from doing so.

Generally speaking, the Columns and Column blocks are designed to use a CSS grid.

The docs has detailed information on how to make best use of the blocks:

Using any other container block such as Section or Div with child blocks will allow you to use display flex.

Please test this for yourself and confirm whether using Div blocks instead of Column blocks resolves this for you.

I tried using the divs instead of columns and it displays fine in the builder, but again, it does not show up on the frontend.

Does that apply to all styles?
Can you check your browser console for potential errors?

It may also be worth regenerating Cwicly CSS, etc from the Cwicly settings tab.

If that doesn’t resolve it, it is possibly a conflict with another plugin or some other code that is causing it not to work.

Ok, I did a bunch more testing - Removing plugins, installing on a fresh subdomain, using the builder on pages/posts, disabling all browser extensions, regenerating css/html, etc.

Here is what I discovered: The Cwicly builder seems to work fine for me on posts and pages.

The whole time I have been building directly within a template assigned to a custom post type. Perhaps I should have been using the template parts instead?

Custom post types should work perfectly well with Cwicly, so this is definitely a mystery that needs to be solved.

How exactly are you assigning the template to the custom post type?

Thanks again for your help.

Here is what I did to assign the template to the custom post type:
Cwicly Themer > In templates tab I chose “+ Default” > Add new > Single Item: (the name of my custom post type)
From there, I selected the created template to edit. Within that template, I can get the contents to display on the frontend, but not the styling.

Did you use ACF to create your custom post type or something else? (e.g. CPT-UI or custom code)

And assuming you have added a Post Content block to the template - does the content from each post display correctly with styles or are those styles not working either?

You may also be interested in this thread regarding the Preview feature - just in case you are previewing and not saving and viewing the site.

I am using ACF’s new built in custom post type functionality. This particular site never used CPTUI.

As for the custom post type in question, I have created a complete custom post type with associated fields and field values. On the frontend, the custom post displays the inputted field values, which I query dynamically with Cwicly. The styling for the template linked to the custom post type is still not coming through.

I am just trying to differentiate between two things:

  1. The content and styling of the template
  2. The content and styling of the post content of one of the custom posts

Is it just point 1 that doesn’t display or is it both 1 and 2?

This is very strange indeed like a text book caching issue. Is your styling in the UI or SCSS or both? Would you have any screenshots of the backend including Cwicly and what you are seeing on the frontend? A screencast even better.

Just to clarify: I have the Cwicly builder loaded in the template assigned to my custom post type - The frontend displays one the content of one of the custom posts.

I tried styling in the one custom post entries I have (not the template) and seems to be working fine. So all is good with posts and pages as far as I can tell.

It’s the template itself that doesn’t pull the css through from the Cwicly UI. I can however manually code the css in the UI’s advanced tab and that works with the template.

I’d upload images, but discourse has restrictions on new accounts and therefore am currently unable to do so.

What is your url structure for the page that is not displaying on the front-end? e.g.:


And I know you mentioned columns before, can you share in more detail the approximate structure of the blocks used in the template.


- Section
  -  Div
    - Post Content
  - Div
    - Heading
    - Paragraph

It may help to understand specifically what is not working. If you had a similar structure to the above and applied a background colour to the section or a font style/colour to the heading, or anything not layout related, would it display? Or is it all styles from the template that are not loading?

Hi @Jack,

Sorry to hear you’re experiencing trouble with this.

Thank you to everyone for jumping in and helping out! :slight_smile:

Since we’re already in communication via email, could you kindly provide support@cwicly.com with a frontend link to your installation, or even better, temporary access?
This would allow me to take a closer look and hopefully pinpoint the issue for you.

Thank you in advance.