Query Template broken with Gutenberg Version 13.9

On the latest Gutenberg update, which is needed to set individual taxonomy-type templates in the full site editor, the Query Template block no longer renders the Cwicly block-options panel. It loads a blank panel instead:

Bump. I suppose no action here means that using the latest features from the Gutenberg plugin are simply unsupported for now?


Hello @avunu,

Thanks for bumping this one.
Sorry for the delay in the reply.

I’ll have to take a look at what is going wrong exactly, and will update here.

Gutenberg’s global-styles-inline-css also overrides Cwicly’s base.css
For instance, Cwicly links will have text decoration of underline.

I don’t use the plugin anymore, just tried to reproduce @avunu’s issue and this came up as well.

Sorry to be a bother, but any update here? My client’s project is held up by this ATM…

Hey @avunu,

I’m sorry for the delay taken to look at this issue.

I tried reproducing it on my side with the latest Gutenberg version but didn’t run into the missing inspector controls issue. Is this happening in every Query → Query Template situation?

On a side note: can’t you set up the taxonomy-type template with the Cwicly theme?

I see that I jumped to the wrong conclusion here. That query template doesn’t work on our site at all. This is happening regardless of whether the Gutenberg plugin is active (or any other plugins that Cwicly). We’ll PM the site credentials so you can take a look.

Also, I misspoke about the custom taxonomy-type template. It’s actually a custom post type template that we’re managing here, and yes, the Gutenberg plugin is required for this at the moment, as far as I can tell.

Hello @avunu,

Thanks for the report.

I think @Araminta helped in this situation by proposing a temporary solution as you didn’t have any posts on your installation which made the Query block (which queries post by default) not display anything.

Version 1.2 should help towards this kind of situation by querying ‘any’ when the Inherit Query from URL property is toggled.

Please let me know if this helps on your side.

Thanks in advance and thanks for taking the time to post here.

This is all making sense. Thanks @Louis!