Two columns in the editor, just one in frontend

Hi guys, a Cwicly new user here.
I have a section with two columns. Both columns have a background video and a fixed height of 500px.
I see the correct rendering in the editor but the frontend renders one column only.

Editor :point_down:


Any help?

Hiya Bites,

Could you include a screenshot of your Cwicly inspector on the Columns Grid window? I would add a div in each column, set the width and height of the div and add the video.

Hi Hopscotch, thanks for your reply.

Here’s the shot of the inspector on the columns:

This is the inspector on the single columns:

Btw, how do I access the grid editor? And why would you add another div inside each column?


Nevermind the question about the grid editor.
Here’s the screenshot of it:

Hi Bites,

I just confirmed it does the same for me. It adds a video overlay div on the same level as your column div (not a child) with the class cc-overlay-video-background and absolute positioning. @Louis is there a way to confine a background video to a column div?

1 Like

@Bites I noticed you got it working. What was it?

@hopscotch I ended up putting the video blocks inside the columns with autoplay and hiding controls instead of use them as the columns background. The problem now is that videos don’t autoplay on iOS devices, even if i set the videos to mute in the editor. Araminta from Cwicly said they will dig deeper on this.

@Bites there support is outstanding with fixes pushed up once a week so I am certain they will have a solution for you.

Hello @bites,

Just fell on your thread thanks to @Araminta and @hopscotch.

Can you possibly try setting the position for the Column block (the one that contains your video) to relative.

We don’t do this by default as we prefer to leave it up to users (although on the Editor, Gutenberg automatically adds relative to all elements…).

Thanks in advance.

1 Like

@Louis many thanks that worked for me. I thought I tried that but obviously not :weary:

Hey @Louis , thank you so much, it worked like a charm!