Some cwicly blocks encounter errors with the latest version

When creating the header template via the cwicly Themer, some blocks display following error message:

“This block has encountered an error and cannot be previewed.”

I have noticed the using with following blocks:

  • Icon
  • Heading
  • Button
  • Div

Steps to reproduce:

  1. Open cwicly Themer
  2. Edit header
  3. Include above stated blocks

Environment info

  • WordPress version: 6.0.2
  • Cwicly Plugin version: 1.2.1.7
  • Cwicly Theme version: 1.0.3

Following Plugins are installed:

  • cwicly
  • WooCommerce
  • WooCommerce Blocks
  • WP Reset Pro

Hi @hejmista,

Thanks for the report and sorry for the inconvenience.
This does seem unusual.

Could you possibly tell me if there are any errors in the browser console appearing?

Thanks.

Hey Louis, of course. Find the error messages from the console as follows:

Hey there.

I am also currently creating a header template.

Just as quick feedback:
So far, I haven’t faced any issues, everything works fine on my side.
I used the Button and Div Blocks.

It’s a fresh installation.

Hey Marius,

which operating system and browser do you use? I am working on a Windows machine with Chrome Version 105.0.5195.102

Also a fresh install. I will test on a Mac and another Windows Machine later - and also in incognito mode. Maybe some chrome extensions are conflicting.

I’m on W11 Pro 22H2, currently using MS Edge v105.0.1343.33

Hi @hejmista,

Are you possibly hosting with Kinsta or is this a local installation?

Adding to my latest comment, are your permalink settings set to default?

If so, could you possibly try switching to another setting to see if this fixes the issue?
We’ll be bringing in a fix for the default permalink setting which is causing an issue with a few of our API requests.

Thanks

1 Like

Hey Louis, I first updated the plugin to the latest version before changing the permalink settings but it didn’t work just in case it is helpful for you. But changing the permalink which was set to plain by default solved the issue. Thank you very much! :slight_smile: It works on both now. The mac and windows laptop. Tested both on chrome.

1 Like

It was an installation on rootpal. :slight_smile:

1 Like

This issue with default permalinks was fixed in 1.2.1.9.

If you still experience any issues, please let us know.