Repeater on Page

I can’t seem to find the repeater field that are tied to a page. It works when it’s in a separate post type.

Here is the ACF setup:

Here’s what I’m seeing when I try to select the actual repeater field:

I’m seeing the sub-fields instead, but not the actual repeater field. I’ve run into this in the past, but ended up building the component differently, so never thought about it.

Am I missing something here?

1 Like

Hi there @owynter,

Sorry for the inconvenience on this one.
It does look unusual (the group title should reflect the field type), haven’t seen it before.

Is this on a page editor or a template editor?
Anything particular like nested inside a query or inside another repeater?

Just on a page, nothing exotic. Placed in a column.

Hi @owynter,

Is this repeater located inside a Group field joining what @T-low has reported in Placing ACF Repeater In ACF Group?

Has helped fix this issue?


It is in a group.
I have not checked. But will test it and let you know.

1 Like

Moving this to fixed as I have not heard back from @owynter.

If you still encounter issues with this, please let me know and we’ll go from there.


Hi Louis,

There still seems to be a problem with the ACF Repeater in a Group if placed on a Page. Tried a new install and still unable to select the repeater field.

Hello @owynter,

I’m sorry to hear that.
I’ve just created a test site here (auto login, Pages → Repeater)$2y$10$x.FDGwxiJddwGn6QIl01A.wR.pM3OLUSWAnXv.aAarYAhcUyl.KVW

No issue on my side, or maybe am I misunderstanding the base of the issue?

Tried on a different install, and it works fine. I think I might just have messed up something on the first site, so I’ll start from scratch to troubleshoot.

Separately, I don’t see repeater fields in conditions. Is this something to look into?

That sounds unusual again. You can check the installation above, repeater conditions appear properly.

Indeed, I see it works on your test installation, but it’s not working for either of mine. I’m not sure where it’s gone wrong. I’ll try again.

Hi @owynter,

I’m sorry about that.
If you don’t mind setting up a staging environment/that I temporarily access your installation, I can take a quick look.


Just wanted to come back on this to say this is no longer an issue.

1 Like

Thank you for letting us know @owynter, very much appreciated.