Remove Template Part Wrapper didn't work

I signed up for the Cwicly 3 sites plan today, did my rapid test, checked the HTML output, and noticed that some outer wrappers are wrapping the first section I added in the Gutenberg editor.

I have enabled Remove Template Part Wrapper in the setting, but it seems not to be working correctly.

Refer to the screenshot below

I did regenerate everything but no luck.
And I also noticed that there are 2 sections with a class cc-sct.

I am looking forward to the feedback.
Thank you!

Environment info

  • WordPress version: 6.0.3
  • Gutenberg Plugin version: -
  • Cwicly Plugin version: 1.2.3
  • Cwicly Theme version: 1.0.3

Hey @jornes.

1.) Here you have some info about the .wp-site-blocks wrapper.

2.) Check your index template, replace the Gutenberg post content block with Cwicly’s one and move it to the root (1st level). It is placed inside a section block by default.

This should remove the 2 wrappers (it’s the section block I mentioned) between .wp-site-blocks and the post content block.

PS: The setting you mentioned does not affect anything inside your current setup. It’s for template parts.

1 Like

Thank you very much, @Marius

I will check it out as soon as I return to my computer again. :smiley:

1 Like

Nice to see you here @jornes, welcome to the forum.

I want to add that the step with replacing the Gutenberg post content block with the Cwicly one is optional but gives you a lot more control in terms of block options and on top a more clean HTML without these WP/Gutenberg classes.

Let me know if it works out for you.

Thanks for the welcome!

Yeah, sure…I’d love to know how.