Regenerate HTML conflict with WP Social Ninja

Hey @Louis ,

Noticed this conflict and thought I’d share in case it’s in any way helpful.

I didn’t have any issues regenerating HTML with 1.2.6, but on 1.2.7 I get this error:

I checked the server log, and this is what I found:

2022/11/11 13:19:30 [error] 3112145#3112145: *358994 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught TypeError: array_values(): Argument #1 ($array) must be of type array, string given in /var/www/
Stack trace:
#0 /var/www/ array_values()
#1 /var/www/ WPSocialReviews\Framework\Foundation\Application->{closure}()
#2 /var/www/ WP_Hook->apply_filters()
#3 /var/www/ WP_Hook->do_action()
#4 /var/www/ do_action()
#5 /var/www/ wp_insert_post()
#6 /var/www/ wp_update_post()
#7 /var/www" while reading response header from upstream, client: 99.999.999.99, server:, request: "POST /wp-json/cwicly/v1/post_html_render?_locale=user HTTP/2.0", upstream: "fastcgi://unix:/var/run/php/", host: "", referrer: ""

De-activating the WP Social Ninja plugin resolves the issue.

Hello @sunny,

Thanks for the report.
This is unusual as we were already using wp_update_post() in our previous versions (the only change on our side is what content is modified).

Do you know if there was a recent update of WP Social Ninja that happened in between?

Will look into this further.


Initially I restored a backup, tried with 1.2.6 still active (worked), tried again immediately after updating to 1.2.7, got the error.

What’s even more strange though is that after I triggered the error, I uploaded an older version of Cwicly (v1., and still got the error.

I’ve never seen the error previously.

Just so you know, I’ve had another conflict issue with WP Social Ninja and SureCart. I’ve opened a support ticket so they can take a look at it.

1 Like

Hi @sunny,

Thanks for the follow-up!
I have planned to see what’s happening on our side when I have a moment, this is helpful info.