Posts in query not displayed when user is not logged in

I am having trouble finding where and how to configure the settings to allow non-logged-in users to view posts in an archive.
Here is the URL: Archive: Posts - Transform Your Business with AI, Marketing, and Management Expertise | Gauthier Bros Consultancy
When a user is logged in, the posts display correctly. Could you please assist me with this?

Hi @weedor,

As the page loads but the frontend rendering never completes, this seems like it could be an issue loading asynchronous responses from the server:

I recommend checking that the public rest api has been enabled for all custom post types and also checking there is nothing blocking the rest API from the server / hosting side.

Thank you, @StrangeTech,
Everything was working fine when I initially launched the site and for a long time afterward. I haven’t made any changes to the API. The problem has only recently arisen.
Could you please advise me on where to check?

Please see this post by @Araminta:

To summarise, if the “Require ACF API REST” setting is enabled in Cwicly settings, you will need to also enable the “Show in REST API” setting for the field groups for the custom posts. Alternatively you can turn both of those settings off and this should also work.

If this doesn’t resolve the issue and refreshing the html and classes from Cwicly settings also doesn’t fix it, then more information about exactly how you have the archive page / query and filters set up will be required.

The only other time I have seen something similar to what is happening on your site is when there was an issue with one of our filters. Fixing the filter resolved the issue in that case.

1 Like

Thank you again, @StrangeTech.
I realized that I hadn’t regenerated the HTML and other components since the last update. After regenerating them, everything is working well now.
I’m sorry for bothering you with such a trivial mistake.