Post Content from Dynamic Data not showing line breaks


I’ve got a blog post set-up, and I’m using the ‘Post Content’ block (from Cwicly) to feed in the content of the post. I’ve also tried using a Cwicly Paragraph block and inserting the dynamic data there.

All line breaks as given in the content editor on the backend (because I’m using Classic Editor) don’t show up in the preview as created through Post Content.

The only way I can insert line breaks is using Shift+Enter in the default Content Editor (from Wordpress) and inserting that into the blog post page. However, I don’t want to keep using this as I want to really give my client a WYSIWYG-editor.

Is this a bug?

Step-by-step reproduction instructions:

  1. Create a post/blog page. Insert a ‘Cwicly Post Content’ or just Cwicly Paragraph (in which case you’ll have to insert the dynamic data as input afterwards).
  2. Activate Classic Editor. Create a blog post and write something in the Content Editor screen. Use ‘normal’ enters to create line breaks. Going back to the blog post page now, you’ll see that those enters don’t show up.

Environment info

  • WordPress version: 5.9.3
  • Gutenberg Plugin version: -
  • Cwicly Plugin version: 1.1.4
  • Cwicly Theme version: 1.0.3

Hi @boris,

Sorry about our lack of reactivity on this.

Unfortunately, I don’t seem to reproduce your issue on my end since my line breaks appear as expected, without having to use Shift+Enter, with the Classic Editor enabled.

Would it be possible for you to provide me with temporary access to your current installation? This way, I can have a better look at what’s going on.​

Thank you.​

Hi @boris,

Since we haven’t heard back from you, we are going to consider this fixed.
If you still experience this issue, please let us know by replying to this thread.