My copy paste does not work for any block

Interesting. I wonder why we’re having different experiences. Maybe it’s my OS, the server where my site is hosted, caching problems on the server, or browser plugins? I don’t think it’s the browser, because tried it in FireFox instead of Chrome, and it’s the same experience.

I do have my family member’s laptops. I suppose I could log-in there and see if it’s any different.

Your last paragraph made me think of a feature request for the Cwicly team. That is, of pop-up notifications that say when you cannot paste, and the reason why. In the same way that it notifies you when you’ve copied successfully. For example, pasting a button into a button would tell you that you can’t do this, and why not. This information would lessen frustration for people who wonder why it doesn’t work.

Yesterday I could not copypaste “at all” actually except for just once I saw a glitch where it worked…
Your system has it work partially.
If other computer does not solve, could you install via XAMP / MAMP? Other host?

For the button issue, it will paste.
It just will paste after the button but not inside the button so you still have a clue that it worked.
Just your experience is unusual I assure you once you get all working :slight_smile:

Second the option to put it back on a toolbar or to remove dependency on keyboard shortcuts. The Ctrl+V and Ctrl+L are not working for me. I’ve managed to get “lucky” a couple of times with Ctrl+V, but it fails almost all the time. I haven’t been able to recreate why enabled me to paste in the rare times it has worked when I spam it out of desperation. Has there been any fix to this? Currently running Version

1 Like

Copy paste block Ctrl+C and Ctrl+V invalid Version

Just chiming in here with another feature I think would be great to see with Copy & Paste is transferring over the selected heading level etc. as well.

I have noticed that say I have a grid of cards, I have initially set the title to a h2 and now want to change them to a h3, if I do that on the first card, copy styles and paste, the css styles are copied which I guess is the expected behaviour, but I guess this would be a nice addition as well?

Not sure if that blurrs the lines a bit and the expected behaviour, not sure if anyone else has also had the same thought?

Just an idea :slight_smile:

Hi @mpm,

Sorry to hear you’re expereincing trouble with this too.

As I had asked @AnthonyKeller, I am not experiencing this issue on my end.

  • Could you specify if this is particularly happening in the Site Editor, Post Editor, Template part Editor…?
  • Does this happen with every element or only specific ones?
  • Are you pasting your element in the Section, Div or Paragraph blocks?

Could you possibly send support@​ an access to this installation so that we may have a closer look at this? Thank you in advance.

Hi @phil22,

This has already been discussed here: Copying a linked div with heading inside: heading element always h1

Feel free to share your thoughts about this subject there so we can keep better track of it.

Copy and paste still don’t work properly for me, on They perform the same as they did 18 days ago when I shared my videos. Ctrl + C works about 80% of the time, while Ctrl + V almost never works. The workaround I’ve found is to hit Ctrl + C, click onto a different element than the one I copied, hit Ctrl + V, and hope it pastes. It usually does not.

I know you’re busy with big projects right now. Can you please look into this in Q1 or Q2? I can send you access to my dev site.

Thank you.

Hi @derekpadula,

Thanks for the update on your issue, sorry to hear it still doesn’t work properly on your end.

If you could possibly send a temporary access to your installation, it would be helpful.

Thank you in advance.

Update from previous posting: Installed Version and copy/paste/link using shortcut keys works for Post and Page Editors now (for me anyways). Linking not available for Page and Template Part editor but Araminta confirmed that it’s a Gutenberg limitation for the time being.

Thank you Cwicly team for always responding so quickly! :wink:


Hello everyone,

Thanks for all your posts and feedback on this subject. brought a few reworks to the Copy/Paste function.
Would appreciate to know if you’ve experienced an improvement.

It’s somewhat better now, but still not fixed. When I type Ctrl + C, it copies as expected. But typing Ctrl + V while still having the block selected does not paste. I have to select the block above the block I copied and then hit Ctrl + V to paste it, and it will paste it at the bottom of the div or section. So if there are a lot of blocks in that div, it will appear at the bottom of the list, rather than next to the block I originally copied. Then I have to drag it into place.

Still no paste option in the navigator right-click menu, nor the Options (…) menu in the block explorer.

Oddly, when I copy a block and then right-click into a space where there is a text field (such as a word in a button), the standard web browser right-click menu for editing text appears, and when I select paste, it pastes the block I copied at the bottom of the section, below the place where I selected to paste. This is true for all blocks, not just with text blocks. Yet the block copied will be empty, without the text, images, or other settings from the block that was copied carried over.

I can record another video for you, or you can log-in to my dev site and try it for yourself.

1 Like

I think you might have Link copy active if none of the block settings are carried over…

Nice topic here. I have the same MacBook Pro from 2019 and same here: cmd V doesn’t work.
I have this also when I work with Gutenberg on my Generatepress sites. duplicate function works only sometimes.

But here it is: It DOES work when I use firefox (developer edition, haven’t tried other browsers) So I guess its more of a safari thing.

Just my 2 cents.

Still, I use safari for all building, so a fix would be great!

I don’t understand, why “Paste” is still missing in right click dropdown on navigation panel?

1 Like

I have experienced the same issue on right click and copying styles. I will try copying with right clicking styles => ‘copy’ ‘copy’ is available but ‘paste’ is missing. It also doesn’t work for Command/Control V. Then I found Copy & Paste styles on the block panel that displays above a block when you click on it. I believe they added it there so you can paste even between different websites which makes loads of sense. Though I would still also have it on right click to avoid confusion.

Even though it works with the keyboard shortcut, I still prefer a paste in the dropdown when right-clicking.

1 Like

Thanks for this tip!
Hardly any block works for me inside the site editor when it comes to pasting, while I have no issues inside the post editor.
But I’ll take that as a workaround.

To the team, if there is anything I can do to investigate on my side in this case (and share stuff with you), please let me know.
Will probably check the situation on another device with different OS later and see how things are going.

1 Like

Sorry to hear this remains an issue on your side, @Marius.

We have conducted multiple tests on both Apple and Microsoft OSs on multiple browsers, and haven’t been able to reproduce any copy/pasting error in the site editor.

Thank you for kindly proposing to share your findings with us, which we would greatly appreciate to get to the bottom of this! :slight_smile:

1 Like

Just did another extensive test drive, unfortunately nothing I could report here.

Again, selecting another block after copying a block (and optionally reselecting the initial block) will do for me to make it work. Really not a big deal, just kind of unfortunate it’s not working the intended and straightforward way.

Thanks again for your feedback @Araminta.

1 Like