My copy paste does not work for any block

Latest Cwicly version.
Is the copy paste broken ?

Whatever block I try to copy, there is no way for me to get other that “copy styles” as per the image.
I tried deactivating all the plugins except Cwicly.

So basically, If I am correct, I should have the options of copy block (duplicate) and copy block (linked) but I don’t see them at all.
I am working from a local env if that can help.

Same here, on a live site. The paste-related commands are missing.

Ctrl + C works, but Ctrl + V does not.

I read somewhere on this forum that Louis is working on revamping copy and paste, but it’s odd that paste would be missing altogether.

Hi @AnthonyKeller and @derekpadula,

Sorry to hear you’re experiencing trouble with this.

I don’t think this is a bug.
In earlier versions, the copy/paste icon in the Block toolbar allowed you to copy/paste elements. However, this has changed since you should now be able to copy/paste elements using keyboard shortcuts, which is preferable in terms of workflow.

  • Copy/paste block (duplicate): Ctrl + C / Ctrl + V
  • Copy/paste block (linked): Ctrl + L (make sure the link copied block icon lights up in orange) / Ctrl + C / Ctrl + V

Please let me know if that helps!

@derekpadula, is this happening on the Site Editor? If you could possibly provide more details on this it would be helpful.
Thank you!


@Araminta Exact same as Derek, copy via command V works, not paste.
Same if I go to paste it in a parent element, I tried all combinations.
I saw it work ONCE as if there was a glitch but despite the orange link line being set, the copied element wasn’t linked.
Again that happened once only and I tried 30 times on various elements : sections, paragraphs, buttons…
As you probably can tell, I am stuck on my current project so sorry to mention @Louis on this too.

I wonder if the person on this thread had the same bug :

I am using a few chrome extensions that may alter the shortcuts, so I will try that on firefox now.

This sounds unusual as I am not experiencing this issue on my end.

Could you specify if this is particularly happening in the Site Editor, Post Editor, Template part Editor…?

Does this happen with every element or only specific ones?

Are you pasting your element in the Section, Div or Paragraph blocks?

1 Like

!!! @Araminta It works :smiley: and the linking too. Cherry on the cake.
I have no idea why.
How to reproduce : I have no real clue, I was on a WP page last night so I thought no big deal it is all regular editing.
Again only Cwicly plugin was installed and still the bug was here.
I reloaded the page multiple times and still.
Like I wrote earlier, I am sure it happened on all elements : sections, paragraphs, buttons were tested.

This morning I went and tried on a post, still same env. and same browser, it worked via copy paste from keyboard (the popup still does not show the copy block (dup. and linked) but as you said, this is expected right ?)
Went back on my previously buggish page and it worked there as well.
Hmmm I just hope this never happens, fingers crossed but the fact @derekpadula had it too makes me wonder if some fix could be found.

Paste does not work in any part of the Cwicly editor, on any element. I cannot copy and paste anywhere, including in the same section or div in which I copied an element.

Copying brings up the notification in the bottom left that an element has been copied. Pasting does not. Nothing happens.

Paste via Ctrl + V stopped working around I want to say in a certain version I was able to get it to work if I repeatedly slammed the keys. This was inconsistent and frustrating, so I learned to compensate by pasting via the mouse in the control bar. Then I upgraded a few days ago, and paste stopped working altogether. So the issue may have been introduced slightly before, and then lost between and

While it may be true that typing Ctrl + V is faster, I’d still like to have the option of pasting via my mouse. Please don’t remove it, if that was your intention.

Hi Derek,
By “control bar”, you mean the block toolbar I showed in the image in 1st post ?
Have you tried another browser? Another post to edit?

I agree that this functionality should stay in the block toolbar to access via mouse click.

Hello @AnthonyKeller and @derekpadula,

Apologies for the trouble you’re experiencing with the copy/paste functions and the inconvenience this might cause, which I can imagine is considerable.

The copy/paste situation in Gutenberg is rather delicate currently… There isn’t an easy way to plug into the native functions which operate specifically (when you paste a block, by default it will replace the block you’ve selected). I won’t go into the Site Editor issues with copy and pasting which make things for us very difficult.

In any case, copy/pasting should function correctly as I can’t seem to reproduce the issues you mention above, so this situation does seem unusual.
Could you possibly let me know what WordPress version you are running?

The block toolbar functions were removed quite some time ago, long before The only issue here is that we now use the native clipboard (which makes it possible to go from one installation to another), which in turn would require HTTPS access on the installation if we wanted to access it to “paste” the block with a toolbar function.

1 Like

By the way, that was great news when I discovered the copy/paste was available cross sites!
I understand the challenge is very high and the mouse click has turned to something different, in that regard all is fine.
I am running WP 6.1.1

After several more sessions of experimentation I was able to get the Ctrl + V paste to work some of the time, but not all of the time, nor consistently. It’s confusing and frustrating.

It took several hours of trial and error with my old computer, but I recorded two videos at the point where I think I figured some of the pattern out.

  • Apologies for the loud keyboard sounds. The first video stopped working a few minutes into it because my hard drive ran out of space, so I recorded a second video to complete my thoughts. And both have broken endings.

Part of the reason for the frustration here is that the logic for what can be copied and pasted has not been explained to us, nor the logic of where it can be pasted. It’s trial and error. What I want is for everything to be copy-able and paste-able, everywhere. One block to somewhere else a block can go, or one section of text somewhere else text can go.

My thinking is that if you can copy a block with the mouse, why can’t you paste a block with the mouse? I’d prefer to have both commands, like it used to be. Same for cutting a block with the mouse. I want it to function like in a code editor or Word document, where I can use the mouse or keyboard commands as my preference dictates at the moment. And I want to be able to copy an element from anywhere and paste it anywhere else, just like I would with code.

Sometimes I feel like I using keyboard shortcuts, and other times I want to point and click. Or to use my right hand to select elements and my left to copy and paste them, so that I don’t have to move my right hand away from the mouse. My second video explains this in more detail. The essential point being that visual people prefer to point and click, not use keyboards, so please don’t limit how people can use your software based on your own logic or preference of what is best. Offer both. If there’s no point and click for pasting on a tablet or other device without a keyboard, what are users going to do?

In addition, Ctrl + Shift + D does not duplicate. Instead, Ctrl + Shift + D turns the sound off on Windows by changing my audio-out source. I then have to manually change the audio-out with the mouse to get it back. Performing the duplicate action with the mouse does work as expected and wanted.

In conclusion, I invested in Cwicly because it’s the only editor that works the way my brain works, while your competitors’ products do not. I like being able to use it by pointing and clicking or use it with the keyboard, or as a mix of both, whenever I feel like it. As you mentioned, I’m sure this is difficult to code, or because of the WordPress team making changes, but please take my preferences into consideration. I’m sure that I am speaking for others as well when I request that you add Paste Block back into the block toolbar.

At the very least, explain the logic of copy and paste in your docs. What elements can be copied and pasted, and where? As it stands, we have no idea unless we spend hours in frustrating trial and error.

Thank you.

  • WordPress is a clean install, at 6.1.1. Cwicly is the only plugin I have installed, at

Additional point about accessibility: There are people who cannot use keyboards. Perhaps their fingers don’t work well, or they don’t have fingers or hands. They need to be able to point and click with other devices, including mouth-held pointers, or to select visible menu options with their voices. If you remove the ability to paste from the menu, then they cannot paste.

Please consider this decision from such a perspective.

I feel sorry for you after watching your first video because the experience is terrible but I can assure you, that for every other user included me now, it works super well.
Now, remember I was in the same situation as you yesterday so I get the frustration.
I am on a 2019 imac so I can’t say if this is your computer.
Maybe try another computer if possible for the time being if this is FSE related and waiting for a fix? Is it possible for you?
To answer further, and provide more testing on your end, I can tell you I am able to copy paste :
Sections inside sections
columns into sections or divs or column
Into all of those I can also paste basic elements with no problem (buttons, p, etc…)

What is of course not possible: copy paste into anything that is not a wrapper by default such as button inside button.

Interesting. I wonder why we’re having different experiences. Maybe it’s my OS, the server where my site is hosted, caching problems on the server, or browser plugins? I don’t think it’s the browser, because tried it in FireFox instead of Chrome, and it’s the same experience.

I do have my family member’s laptops. I suppose I could log-in there and see if it’s any different.

Your last paragraph made me think of a feature request for the Cwicly team. That is, of pop-up notifications that say when you cannot paste, and the reason why. In the same way that it notifies you when you’ve copied successfully. For example, pasting a button into a button would tell you that you can’t do this, and why not. This information would lessen frustration for people who wonder why it doesn’t work.

Yesterday I could not copypaste “at all” actually except for just once I saw a glitch where it worked…
Your system has it work partially.
If other computer does not solve, could you install via XAMP / MAMP? Other host?

For the button issue, it will paste.
It just will paste after the button but not inside the button so you still have a clue that it worked.
Just your experience is unusual I assure you once you get all working :slight_smile:

Second the option to put it back on a toolbar or to remove dependency on keyboard shortcuts. The Ctrl+V and Ctrl+L are not working for me. I’ve managed to get “lucky” a couple of times with Ctrl+V, but it fails almost all the time. I haven’t been able to recreate why enabled me to paste in the rare times it has worked when I spam it out of desperation. Has there been any fix to this? Currently running Version

1 Like

Copy paste block Ctrl+C and Ctrl+V invalid Version

Just chiming in here with another feature I think would be great to see with Copy & Paste is transferring over the selected heading level etc. as well.

I have noticed that say I have a grid of cards, I have initially set the title to a h2 and now want to change them to a h3, if I do that on the first card, copy styles and paste, the css styles are copied which I guess is the expected behaviour, but I guess this would be a nice addition as well?

Not sure if that blurrs the lines a bit and the expected behaviour, not sure if anyone else has also had the same thought?

Just an idea :slight_smile:

Hi @mpm,

Sorry to hear you’re expereincing trouble with this too.

As I had asked @AnthonyKeller, I am not experiencing this issue on my end.

  • Could you specify if this is particularly happening in the Site Editor, Post Editor, Template part Editor…?
  • Does this happen with every element or only specific ones?
  • Are you pasting your element in the Section, Div or Paragraph blocks?

Could you possibly send support@​ an access to this installation so that we may have a closer look at this? Thank you in advance.

Hi @phil22,

This has already been discussed here: Copying a linked div with heading inside: heading element always h1

Feel free to share your thoughts about this subject there so we can keep better track of it.