Menu Block

When editing the menu block inside a (header) template part, I experience unexpected behaviour.
It’s only inside the builder, front-end is fine.
To confirm the issue, I placed the menu block outside the container on 1st level. Issue persists.

  • List-style-type on the menu items is shown
  • The layout option is not working properly

I also miss the option to add a custom tag.
Wasn’t that available at some point?

Video

Hi Marius,

Might you be using HTTP auth? Gutenberg currently has trouble with this as they access css files through http requests…

Only current solution is to remove this and go through another restrictive solution.

Thanks for hinting me @Louis :+1:

I’m currently using Local WP.
There were always issues with the SSL option, at least for me.
Could be a Windows (Defender) thing.

Will troubleshoot and update with results.

We use Local WP on a daily basis here also.

Definitely some type of access issue, which you should see in the browser console when accessing the Site Editor.

Can you confirm the issue @Louis?

Here is my console log:

Edit: As you can see, it’s actually plugin related.
Disabling the plugin, no error shows up.

Local WP:

image

Live Server:

I cannot confirm the issue since this doesn’t seem to be related to Cwicly.

I’m seeing an issue with the plugin WP-Revisions-Control indeed, this could explain why the Cwicly styles are not being imported (stopping the parsing process?).

Is this plugin installed on your Live Server?

No.

I now have deactivated and deleted every plugin but Cwicly.
Issue remains.

I want to add that this only happens inside the Themer when editing templates/template parts.
Might not be related but had to create every template part twice, the first one never got saved. At least they were/are not visible.

Not sure what happens here but since there isn’t an issue on my live installation, it’s probably Local WP related.

I’ll create a new local installation and see what happens.

Thank you for the input so far @Louis. Much appreciated.

Update
I set up a fresh installation on my live server.
Same settings, same plugins, same assets. It’s basically a 1:1 clone.
No issues at all, which confirms for me it’s a Local WP / server setup thing.
Won’t dig deeper here but will pick it up soon as I have some more time or so.
Again, thank you, Louis.

A quick follow-up here.

Found an old installation (v1.0.9.2.5), same issue. Here as well: No console errors.

I have to mention that I need to make some tweaks to use Local WP in general:

No clue if this could be related.
I know this is probably an individual issue and not Cwicly related, so I appreciate any input.
At some point, I need to get these 2 tools work together, so I start digging now.

I installed Local WP on a different device today.
No changes were made inside the server configuration, no changes were made at all.

It took me around 30min to install the Cwicly plugin and theme, create a menu and place it inside the index template.
But I deciced to go for it, since I needed to investigate further.

Plugins: Cwicly
Themes: Cwicly

Results are the same.
Tried with Edge and Firefox.

Is there anyone who is using Cwicly with Local WP on a Windows (11) machine?

Yes I do with USBWebserver
It is quite about 5 minutes to create a new install from scratch.
It is 100% portable and very light.

Thanks for your input @weedor.

It’s actually about Local WP, not about local WordPress installations in general.
But I do appreciate your feedback.

Well, the installation is not the issue, it takes under a minute.
There is a general problem/conflict with this tool when using it on Windows, tons of threads exist about it in their forum.
Not everyone is facing it, I think it’s still unclear what the actual issue is.
There is a workaround and I learned today that this is not linked to it which I considered in the post before.

Local WP is a great tool. It’s blazing fast and comes with a really good user experience.
I don’t know about any other tool which comes close, so I’m a bit concerned if I can ever use it with Cwicly.
It’s not only about the mentioned issue with the Menu Block here.
I need to know what’s actually going on before starting a project with this tool.

ok, sorry for the mistake.
I don’t know anything about this tool. I clicked on the link and I think I will dig up a bit. I am always interested by new tools (for me). I discovered Figma like that!

Hello @Marius,

It still isn’t clear from your posts what error you’re getting.

Are you still getting this error?

Here is my console log:

Hey @Louis.

The error only occurs when the plugin is active. It is not related to the issue.

As stated earlier today, I installed Local WP on another device.
The only installed and active tools were the Cwicly theme and plugin.
The only thing i did was creating a menu and tested it inside the index template.

Nothing were changed inside the installation/server files.
No errors do appear in the console.

@Marius, thanks for the precision. Are you sure there are not any warnings in the browser console? As said further up, Gutenberg fetches editor files. If the menu and other styling options are not correctly shown in the Site Editor, this means there is some type of access issue.

Live Server

Local WP

I haven’t tried the menu, but Cwicly runs super fast on Local + Mac & Firefox for me.

1 Like

Thanks for the feedback, much appreciated.
I think Louis mentioned as well they do use it on a daily basis without issues but I think they are on Mac as well.

@Marius: Try it once on Laragon on Windows.

Which conclusion could I draw from doing that @dranzer?
Do you think it could be a general Windows issue, rather than a LocalWP/Cwicly one?