Having problem with masonry layout after lates update

After lates update ( my query grid with masonry layout got broken. See image

So I played around to see whats happened and how to fix it and noticed that if under query template settings I set “grid” and enable Masonry then it breaks and looks as in image above.
But If in query template settings I select grid, then enable Masonry and then deselect “grid” (or select “flex”) then it gets back to normal.

So I assume it is bug because you cannot select masonry layout without selecting “grid”. But for it to work you have to deselect “grid” after then. Don’t think it is expected behaviour.

Anyone else has this problem?

Step-by-step reproduction:

  1. Add query and query template to page
  2. Select any post type to display, add image and title to visually see
  3. In query template settings select “grid” and Masonry - that is where it breaks
  4. Leave Masonry selected and deselect “grid” - that is where it gets back to normal.

Environment info

  • WordPress version: 6.1.1
  • Cwicly Plugin version:
1 Like

Hello @krievinshj,

Apologies for this bug, which was unfortunately introduced in the last update.
Thanks for the detailed report, much appreciated.
We’ll have a fix for it later today.

Thanks for your patience.


Fixed in Thanks for the report.

Thanks @Louis for fixing Masonry layout!
However now I have different problem with the latest version ( Seems that some styling is not loaded in backend.
When editing header I see this:

But it should look like this:

Both screenshots are from backend.

Same is when editing page. In page template I have set wrapper 1300px wide centered and when editing page it was respecting that rule and content was 1300px wide centered.
Now everything in page is full width.
So I have feeling that some styling is not loading for backend.
Tried to regenerate blocks html and css, clean cache.
All this is for backend. Frontend seems ok.

Hello @krievinshj,

Glad to hear that got fixed.

As for the issue you’re experiencing on the backend, might I ask if you have enabled HTTP Authentification by any change?

Yes, that was it!
I did updating on staging site and then realised that it has HTTP Authentification.
Works fine on Live site.