Fragment order in Global Header not working


I have created two fragments, a header and a hero section, which I have added to the Global Header in the Cwicly themer. No matter what order I add them in, the hero section is always shown on top and the header below.

FYI the hero fragment was created after the header fragment, which means it has a more recent publishing date.

The hero section also has a visibility condition to only show it on certain pages, but removing that does not change anything.

Environment info

All software updated to the latest versions.
Using Cwicly theme, and besides Cwicly plugin only Updraftplus and Temporary Login without a Password are active.

Hi @jipsa,

Welcome to the community :slight_smile:

Sorry to hear you’re experiencing trouble with this.

This seems strange, as the order in which you add the template parts to the fragment should be respected.
On my end this is working as expected.

To investigate further, could you possibly provide a temporary access to this installation?

If this is possible, for security and privacy reasons, kindly send the details using our paste website, by sharing the link generated through email to

Please follow these steps:

  • Visit our designated paste website:
  • Input your installation details into the provided text field.
  • After entering the information, the website will generate a unique link for your submission.
  • Share this generated link with us through email.

Thank you in advance.

Okay, never mind, I figured it out. My header fragment was actually not showing in the global header, as I had not set any display condition for it. I assumed that not setting a condition meant showing it everywhere, as I was seeing it on all pages.
However, it was just showing because the header was set to show in the index template. That’s why it was below the hero fragement in the global header.
Sorry for taking your time. Still finding my way around a new system.

1 Like

Thank you for getting back to me on this, @jipsa.

No worries at all!
I’m glad you were able to identify the issue.

If you have any more questions or run into further challenges, please don’t hesitate to let me know.