Extra space around editor canvas and extra scrollbars in non iframe editor

Cwicly Plugin version:


I’ve noticed recently this issue with the editor on my 2 last installs.

There’s an horizontal scrollbar and a second vertical scrollbar even in desktop view, some empty space on the right of the canvas, some space below canvas and below last element in page.

I removed all custom CSS, and it happens with both posts and templates, at any scale, empty pages or large pages, with sections or only plain text… cant’ find any clue.

(The double vertical scrolling is very clumsy and annoying.)

EDIT: Doesn’t seem to happen when editing template parts like header/footer.

It seems there’s something affecting this behaviour, though, the browser zoom level.
When zooming out, the empty spaces disappears and the horizontal scrollbar, but at 100% or above, it reappears. Sometimes it does not happen at 100%…
The double vertical scrollbar remains, though.

Anyone else???

Hello @yankiara,

Thanks for the report.
I’m not able to reproduce this on my end.

Before going further, can you confirm that this is happening on the sandbox installation: https://app.instawp.io/wordpress-auto-login?site=%242y%2410%24fTf6Qq1hSCSBlttOZkYIZe7Ssacqfy0WVxQq0RQXpbTk77DF68..W

Thanks in advance.


Hi @Louis,

Thanks, no I can’t reproduce it, but I noticed something strange…

On the sites where the issue happens, when I inspect the code, it looks like the editor is not using an iframe.
Also, I can’t seem to reproduce it with templates any longer, or maybe I have been mixing things up when opening the bug.

So, what would make that on a some sites, editing a post uses iframe and on others not?
Knowing that all sites use a page template with a Cwicly post content block inside.

OK new update, I could fix the editor with this option checked:

So, what are those certain condition mentioned here that could prevent Gutenberg to launch the iframe mode? And can we do something about it ?

I guess this is related:

As I understand it, this kind of thing is exactly what @Louis added the Force iFrame settings for.

There are several enhancements available with the iFrame version that have been discussed in different threads.

For example:

I have actually ran into this issue as well.

I can confirm that I actually have this issue as well.