Dark mode not keeping dark / light mode after page reloade and premade toggle not working


Hello I sm working on this site - https://staging18.dreamaudio.eu/
I implemented dark mode for now it works only in automatic mode how it should.
But when I toggle .dark class it doesnt stay in this state after clicking on other links (for example product.)

Next I was not able to figure out how to make premade toggle working.
I made my own click action and it works but after each load it is being reset in original state which is dictated by OS.

Here is video of my issue. (Or Am i missing samthing?)

Environment info

  • WordPress version: 6.4.2
  • Cwicly Plugin version:

Hi @JohnySvitana,

Sorry to hear you’re experiencing trouble with this.

This is strange, as it is working as expected on my end.

The interaction you set up won’t work, as it doesn’t persist the data.
This is where the Toggle action link comes into play, where all the logic is set up for you.

To investigate further, could you possibly provide a temporary access?

If this is possible, for security and privacy reasons, kindly send the details using our paste website, by sharing the link generated through email to support@cwicly.com.

Please follow these steps:

  • Visit our designated paste website: https://paste.cwicly.com/
  • Input your installation details into the provided text field.
  • After entering the information, the website will generate a unique link for your submission.
  • Share this generated link with us through email.

Thank you in advance.

Yes I am aware of data persistence not being in work in simple interaction setup.
I also tried to disable all of my plugins. But it didn’t help.

Thank you fo looking into this.

1 Like

Hello @JohnySvitana,

Thanks for the access details.
I can confirm there is an issue with the dark mode toggle action when set in specific situations.

We will have a fix for this in the next update.

Thanks for your understanding.


Hello @Louis,

Thanks a lot for your effort.
I am glad that it can be fixed.

Once again, thank you for bringing this to our attention @JohnySvitana!

This should now be fixed with

Kindly let me know if this is the case on your end.

Thank you in advance.

1 Like


It is working and I think that it worked before to. :smiley:
I have updated my plugin and it was still not working so i was like … nooo it has to work.
I have tried to create new clean div with nothing in it. And it worked and the difference between my original div and new was that i had Icon in original.

So i think that it was not working because I was clicking on icon not a div itself.
Next i downgraded to plain 1.4 (before update) and made the original div bigger than icon it worked!!

So I think that you have found som other bug :smiley: which needed to be fixed.

Thanks a lot!