Cwicly crashed when updating from v1. to latest one

I’m using cwicly in local development with Local by Flywheel.

Since version v1. and v1.3-beta2 that works, i can’t update anymore from v1.2.9.9 to v1. on my local development environment.

The website freeze and the server crashs, i have to delete the cwicly plugin folder manually and restart the server to start again the local website.

I have only cwicly plugin activate and the cwicly theme 1.0.3, nothing else.

Thank you for any input

Environment info

  • Local by Flywheel: 7.1.2
  • WordPress version: 6.2.2 - 6.3
  • Cwicly Plugin version: -

Hello @JRGWxRxZ,

Sorry to hear you’re having trouble with updating to the latest Cwicly release.

Could you possibly enable your debug log to see if anything gets reported there?
Can you also confirm your PHP version?

Thanks in advance.


Hi Louis,

Sorry, i forgot the principal :smiley:. The PHP version is 8.1.9, MySQL 8.0.16 and Web server NGinx.

Error debug.log Message :

[09-Aug-2023 07:19:28 UTC] PHP Deprecated: Return type of WP_CLI\Iterators\Transform::current() should either be compatible with IteratorIterator::current(): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in phar://C:/Users/jrgre/AppData/Local/Programs/Local/resources/extraResources/bin/wp-cli/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Iterators/Transform.php on line 18
[09-Aug-2023 07:26:17 UTC] PHP Fatal error: Allowed memory size of 805306368 bytes exhausted (tried to allocate 12288 bytes) in C:\Users\jrgre\Local Sites\demo02-cwicly\app\public\wp-includes\functions.php on line 650

Thank you for the help


Thanks for that.
It does seem unusual indeed… I can’t reproduce it on my end when updating from to with the same params.
The debug suggests a memory issue, which also sounds odd considering you don’t have other plugins installed.

Is this using the automatic update procedure?

Yes Louis, i tried both method, automatic update and manual update either works, only the v1. and v1.3-beta2 upgrade works.

Ok. If I understand correctly, it updates to but then doesn’t allow you to access the dashboard because it freezes?

Can you try downloading the plugin from your dashboard and manually replacing it inside the plugin directory?

Thanks in advance.

I tried what you suggest, i extracted manually the pluging inside the plugins folder and the result stills the same, a blank freeze screen.


Here the message i have after some time :

Fatal error : Allowed memory size of 805306368 bytes exhausted (tried to allocate 12288 bytes) in C:\Users\jrgre\Local Sites\demo02-cwicly\app\public\wp-includes\functions.php on line 650

And here the functions.php code

( is_serialized( $data ) ) { // Don’t attempt to unserialize data that wasn’t serialized going in.
return @unserialize( trim( $data ) ); //line 650

return $data;



Hello @JRGWxRxZ,

I can’t currently see what could be going wrong, sorry for this.
Can you try setting up a new installation and see if you have trouble there?

Also, is this on WordPress 6.3? If so, could you try rolling back to 6.2.2 and see if the issue still arises?
I see that you reported: WordPress version: 6.2.2 - 6.3 but am not sure if that means you tested it on both.

Finally, can you try increasing your PHP memory limit?

Thanks in advance.


Hi Louis,

Problem solved!

I tried the different advice you gave me, but any success. I set up a new installation and everything works fine.

I think probably, i screwed my previous installation i don’t know how ? And why only v1. and v1.3-beta2 version were working and not the recent upgrade, mistery :thinking: but is not related to php memory limit or wordpress version.

Thank you so much for your kind support :wave: and helped me sort it out this.

Merci cher ami

Hey @JRGWxRxZ,

Thanks for the update! I’m glad to hear that you don’t have trouble with new installations, that’s one step in the right direction :slight_smile:

This issue does sound quite unusual, and I’ll keep it listed in my bug tracker. If you have the possibility to send me an export of the local (providing there isn’t any private material within the installation), I’d really appreciate taking a look at it and seeing if I can reproduce the bug on my end.

Thanks for your patience and understanding on this one.


Hi Louis,

How do you want i’m sending it to you? the filesize is roughly 29Mo.


Whatever suits you best, a Google Drive, Dropbox link or service that respects privacy if necessary.
Thanks for taking the time.