Cwicly containers break shortcode from 3rd party pluging

Description:
This issue is possibly related to this one.

I’m encountering an issue when trying to display a block via shortcode generated by WP Maps Pro. I’ve been struggling to find a solution to add Google maps to my site via ACF for over a month now. Nothing has worked so far.

WP Maps Pro seems to work, but I am getting an error in the console on the frontend. Testing in a number of different environments, revealed that when wrapped in any Cwicly container, the shortcode breaks.

I used a barebones Gutenberg installation as a control, and it worked as expected there. Once I installed Cwicly and wrapped the shortcode with a DIV, it breaks.

Here’s a video (it’s 10min, sorry), where I explain and demonstrate the problem.
https://jam.dev/c/7135d1ba-52fd-416c-8d8e-f9ac31e7bcc8

  • WordPress version: 6.1.1
  • Cwicly Plugin version: 1.2.9.2.3

I can share access to the InstaWP test site for you to review.

As a follow-up. I’ve still been trying to find workarounds and doing troubleshooting on my own.

To be clear, the issue I outlined above remains.

However, my immediate need to display a dynamic Google Map has been addressed by consulting ACF’s documentation and using the code provided on this page: ACF | Google Map

I previously tried and was unsuccessful. What I now realize is that Google Maps requires jQuery to be loaded on the page the map is being called.

By adding a code snippet that enqueues jQuery for this post type my map works just fine.

I imagine that Cwicly (very wisely) disables jQuery by default. Is there a way to get it to run conditionally, otherwise? It’s possible I might have missed something else.

Apologies, as this is outside my realm of knowledge, generally.