CPTs not showing up in Role Editor

Hey Louis,

I saw in the latest version that you can “Specify Post Types for Cwicly features & blocks in Role Editor.”

I think this is a great feature, however, I noticed that none of my post types made with CPTUI are showing up. Only Pages, Posts, and post types created by a plugin.

Hi @sunny,

That’s strange. We always test our CTPs with CPT UI.
Are you sure your custom post types are available/showing in REST API?

Hey @Louis,

Yeah, they have REST API enabled and are visible if I poll the site through https://wp-api-explorer.pages.dev/.

Anything else that I could test for?

EDIT: P.S. you should update Cwicly to the latest version on the sandbox site. I tried to test my CPTs there but it’s still running :slight_smile:

@sunny Regarding sandbox site…I think they can set it to auto update once they solve the license key field issue. Right now if you change the input to text for the license field then you can see the license. It’s related to this. Mask License keys - Feature Requests - Cwicly

1 Like

Will get the sandbox updated later today, would greatly appreciate if you can test and see if you’re getting the same result there so we can see what’s going wrong :+1:

1 Like

Hah, I think I have it.

Can you check to see that there isn’t a limit of 5 post types that show up in this section?

Wow, nice find!
Weirdly enough this was not happening on any of our installations, even the new ones.
Finally reproduced on a different hosting platform.

Thanks for persevering, will have a fix for it in the next update!

1 Like

That is a weird one! Glad you were finally able to reproduce.

1 Like

Hello @sunny,

Thanks for bringing this up.
Should be fixed in