Container styling not applied after Global Styles CSS regeneration

Have noticed this for the last couple updates.

I have a global style for my containers set like this:

I leave the class field blank, and the styling applies to the base .cc-cntr class for containers.

When I regenerate Global Styles CSS though, I noticed that the styling no longer applies.

If I go back into the global styles, type anything into the “Class” field and then delete it, all works normally again.


Thanks so much for your report!

Is there any error in the browser’s Developer Console when regenerating the Global Styles CSS?

Best regards,

No console errors - it regenerates them successfully.

I also noticed that simply opening the Global Styles panel restores the container styling.

But until I do that, the styling isn’t applied on the front-end.


We made a few changes in the previous update for Global Styles regeneration. Is this still an issue for you?

Best regards,

It didn’t break after yesterday’s update, so it looks like it’s fixed now. Thanks again!

EDIT: Nvm, I just updated today and the same issue is occurring.


That’s unfortunate.
Would you be so kind as to have a quick look at this sandbox to see if the same thing happens? The Hello World post has a default section/container block.

I have not been able to reproduce the issue this far.

Best regards,

Hey Johnny,

Luckily, I was able to replicate on the sandbox. Here’s the test page: Test – cwiclydemo

Currently it looks as intended. If you Regenerate Global Styles CSS, you’ll see the styling disappear.
To get it back, go into a page and click update.

This can be repeated many times.

Possibly the missing piece here is that I needed to activate the “Remove Container Block Display Properties” setting for things to break.


Thanks for taking the time to look at that and guiding me through it.
I can finally confirm an issue with layout properties when editing global block elements.

EDIT: also confirming this isn’t related to the “Remove Container Block Display Properties” setting

I have added it to the bug tracker. A fix should be available in the next update.

Best regards,

1 Like