"WooCommerce" Template Errors with CWICLY blocks

Hi Team,

I know you are working on the WooCommerce block functionality. (Which I’m really looking forward to). However, in the meantime, we need to customise those template pages ourselves.

I ran in to an error where it doesn’t matter what padding, margin, flexing etc you do with cwicly blocks. It removes all of those CSS settings and just give you the div/section (and the the product content - the block that you shouldn’t remove).

I’ve deactive ALL plugins except CWICLY and WooCommerce (and did a combination of settings to see if I miss something).

I did however found an interim solution - by using any other block (like Gutenburg originals) then the changes are applied. Also, to customise the Single Product layout (while you’re busy, I started using another WooCom Block just to customise the layout). CWICLY does pull the “template” I create correctly in the “Do not Delete” section. BUT, even if I use CWICLY blocks in this template (as you create it in Gutenburg) - all the CSS is removed (unless I use non-cwicly blocks)

Hope it helps, and hope its a bug or something I’m missing, because I need to do a lot of CSS coding now - which CWICLY does so easily for me (if it works correctly :slight_smile: )

It’s not major - just wanted to bring it to your attention and assist the development

Hi there @Oelof,

Sorry for the trouble you’ve had with WooCommerce CSS not loading.
By default, we chose to remove it as we were originally going to work with the WooCommerce functions etc… This has changed with the first instalment we’ll be introducing this week.

In the meantime, you can go to the Cwicly Settings → Advanced Settings and should be able to find the relative WooCommerce settings: Settings - Documentation

If you still have trouble with this, please don’t hesitate to let me know.


Hi @Louis

The WooCommerce settings work correctly as per the documentation.
It’s the other blocks (especially cwicly) that does not generate as per the selected template.

  1. Template Part (Header & Footer) loads correctly.
  2. WooCommerce default or no CSS (as per settings) - loads correctly
  3. If any ‘other blocks’ gets added to the template (above/below the WooCommerce placeholder) - those blocks’ CSS styling are not carried through - just the div/section show but not associated CSS


  • Template Part (Header)
  • Add DIV with top padding 100px
    – WooCommerce place holder (Do not delete)
    – Template Part (Footer)

When you inspect the element once the page load with template, the 100px top padding is not rendered in the DIV. Just a very simple example

I’m happy to let you focus on WooCoommerce functions etc. and will wait for the update as I’m sure the issue I’m experiencing now will be resolved by default. (I have found a workaround in the meantime).

Hi @Oelof,

Thanks for specifying that, much appreciated.
Is this happening on the default WooCommerce templates or a custom one created with Cwicly?

I’m not able to reproduce this on my side and the Cwicly CSS is properly loaded.
Are there any errors that might be appearing on the frontend in the browser console?

Thanks in advance.

Hi @Louis

No problem. Yes on the default WooCommerce templates. (After I experienced the above issues, I did also create a custom and applied to Product only - had to copy the “Do not delete” placeholder as there was no option to insert that). Same result

I double checked again for you.
Yes on default WooCommerce template
Yes on Custom
No errors in frontent browser.

I also swicthed from Cwicly child to just the Cwicly Theme - same result
Not sure if it has something to do with multisite? (ps I use Subdomains - but there is nothing that is actived accross the sites that should/could make an impact - I did also deactivate all plugins on the subdomain to except Cwicly and WooCommerce)

Thanks for the reply and checking thou, I do appreciate it
But maybe I’m the only one - so please don’t spend all your time on this


Hi @Louis

Just some feedback - after some more testing

  1. I reset the WooCom Products template - issue was still present
  2. Created a Default Custom Template for Product
    Added blocks/elements - and rendered correctly (YAY)
  3. Copy that "Group with WooCom Placeholder over to Original WooCom Products template
    Issue was back again

– Edited Post –
Long story short… It seems the product that was used as default was “faulty” and that caused the non-rendering. All templates work (Original, default and custom). It was a WooCommerce issue (which I still can’t figure out). I suspect all the post revisions the datatables might created an error. After I cleaned the database all seems to be working very well

You can close this - thank again for the efforts

Hi, I have the same exact problem. Could you elaborate on your work-around?

Hi @mantasb
This was a very long time ago - I literally can’t recall what I did exactly as I since changed my website and interfaces. But I’m sure following steps 1-3 will might resolve our issue. There have been a lot of improvements made to CWICLY since I posted this. It might not be relevant anymore

The Louis and the team very helpful (with a quick turnaround time)
Might be worth posting and asking on your exact problem

Hope the Steps 1-3 help in the meantime
All the best