Visibilty icon in navigator

The icon of visibility is not set in the navigator

Environment info

  • WordPress version: 6.0.1
  • Gutenberg Plugin version: not installed
  • Cwicly Plugin version: 1.1.8.5.7
  • Cwicly Theme version: 1.0.3

Hey @weedor.
These are 2 different settings.

Inside the Navigator, you can hide elements inside the FSE environment.

Inside the Designer, it’s the CSS property of visibility. You can set it to visible or hidden.

You are right but even if both are hidden, the frontend remains visible.

This clearly shouldn’t happen.
Can’t confirm any issues at the moment, not able to test things right now.

Can I ask you why you don’t use the display property and set it to none? For me it would make more sense but of course, you have the better idea of your own design.

Hello @weedor.
I checked on my end and don’t seem to have the issue of my element being visible after both the icon and visibility property being active.

Could you detail exactly what’s not working for you?

In fact, I got a strange behavior.
I set to a Div:

  • Slashed-eye in navigator
  • Design>Layout>"glasses>Slashed-eye
  • Design>Layout>Display>None
    and the Div still remains visible frontend.

But this is not what I am asking for.
All the settings above concern the display, not the code generation.
I want, if possible, to have a flag that avoid the code generation of frontend HTML for the block tagged.