Query pagination is not working when inherit query from URL is active


Query pagination is not working when “inherit query from URL” is active.

When “inherit query from URL” is inactive the pagination works.

Hi yogi,

We currently have this working with the latest Cwicly version.

Notably, we are using the default index template and do not have front-end rendering turned on.

It may be worthwhile sharing a bit more detail about which template you are using, how you have setup the query and what exactly happens when it doesn’t work, so you can get the issue resolved faster.

@StrangeTech Thanks for your reply.

I am on the latest cwicly version. Using it on the Archive template.

Pagination is not rendered at all on the frontend.



When I disable this it works fine.

What is the difference you are noticing between it working and not working?

Here is a chain of sequential questions that may help narrow it down:

  1. Do the pagination numbers display correctly?
  2. Are they clickable?
  3. Does the URL change?
  4. Does the page refresh?

OK, I just noticed you mentioned this.

Just to confirm, is this purely a visibility issue or are they not output within the HTML of the page at all?

One other question - if you wrap them in a div with a class name, is that output correctly and if so, what are the contents?

@StrangeTech Thanks for checking it.


It is returning an empty div.

Below is the image with “inherit from query url” off.


What data are you expecting to be returned from the query of the page the template is applied to?

It is worth checking whether the WordPress query loop is actually operating on the posts you are expecting as if it is not, this may not be a Cwicly issue.

For the post type you are applying the template to, a good starting point is to double check that your url is the same as archive url you specified in the post type definition.

And you may also want to double check that the number of posts per page you have set in the WordPress settings is not greater than the number of posts of that post type.

The query is working perfectly fine as it is returning the right data. Pagination is the only thing that is not working.

If that is the case, then the only difference between our working query with pagination and your non-working query within pagination is the template type.

Perhaps try using the index template and see if that works better (unless something is preventing you from doing so).

Looking once again at your screenshots, I see that you are simply querying the default Post type in the Query Editor when not inheriting from URL.

Have you assigned the page that you are using for the archive as the Posts page in the WordPress settings?

Or have you used another method to tell WordPress to query the posts within that page?


I am using it with taxonomies.

I appreciate that, I am referring to how the page knows which posts to display, not the blocks you are using in the query template to display each post.

With the Archive template, are you directly assigning it to a page via the page’s template property or are you using a visibility condition in the Cwicly Themer?



@StrangeTech I really appreciate your efforts in looking into this and helping me out.

For now, it is working as I want. I enabled the Frontend rendering and pagination started being displayed on the frontend.


Once again thanks for your efforts.

Hi @yogi,

Sorry to hear you’re experiencing trouble with this.

Thank you for helping out, @StrangeTech!

We have received your support request through email, but I will reply here so that anyone that experiences a similar issue may benefit from this exchange.

Could you possibly provide a screenshot of what your pagination looks like on the frontend, with frontend rendering enabled?
If it displays only one pagination number, then this might be related to the Settings > Reading > “Blog pages show at most” setting.
If you could also provide a screenshot of that setting on your installation, it might help.

Thank you in advance.

Hi @Araminta

As mentioned above the issue is solved for now.

Here are the screenshots.

cwicly-pagination FE


Hi @yogi,

I’m glad you were able to get this working.

Just out of curiosity, I just want to check whether you are using the Archive template for the home page or a different page, as looking at your screenshot of the reading settings, I see you are displaying latest posts there rather than using an explicit page.

Depending on the answer, it may explain why you were getting the original results you described.

Hi @StrangeTech

I am using the Front Page template for the home page and the Archive template for the post archives.

Thank you for the screenshots, @yogi.

I have the same setup but cannot reproduce this error.

To be clear, enabling frontend rendering is not something that should be required to resolve this issue.

However, as we are unable to reproduce the issue on our end and it doesn’t seem to be causing significant inconvenience for you at this time, we won’t be able to provide a definitive solution.

To investigate this further, I can set up a demo instance for you to replicate the issue at your convenience, if it isn’t too much trouble.
Let me know and I’ll get the necessary ready.

Thank you in advance.


Thanks, you can share the demo instance I will try to reproduce the issue.

So, on that basis, it is still unclear which method you are using to let WordPress know that the page you are applying the Archive template to is the posts page.

I believe this specific detail may directly lead to the cause of what you are experiencing.

Are you using any visibility conditions for the template at all? Did you choose the option to display for all posts when selecting the template in the first place?

Hi @Araminta @StrangeTech

I have created a demo instance and reproduced the issue. @Araminta I have shared the login details on cwicly support email.

@StrangeTech you can dm your email to me if you need access to the demo installation.


1 Like