Query Builder: CPT not shown


I’ve added a CPT with the help of the Plugin “Advanced Custom Fields: Extended”.
In the Query builder the CPT is not selectable. Just the default options are there.

Step-by-step reproduction instructions:

  1. Create a CPT with “Advanced Custom Fields: Extended” Plugin
  2. Add a post of the new CPT
  3. Create a Page and add the Query Block
  4. Try to find the CPT in the Post type select field

Screenshots, screen recording, code snippet

Environment info

WordPress Version: 6.0.1

Active Theme:

  • Cwicly Theme (cwicly), version: 1.0.3

Active Plugins:

  • Advanced Custom Fields: Extended: version:
  • Cwicly: version:
  • motion.page: version: 1.5.2
  • Safe SVG: version: 2.0.2

Server (Flywheel local):

  • server_architecture: Darwin 21.5.0 x86_64
  • httpd_software: nginx/1.16.0
  • php_version: 7.4.1 64bit
  • php_sapi: fpm-fcgi
  • max_input_variables: 4000
  • time_limit: 1200
  • memory_limit: 256M
  • max_input_time: 600
  • upload_max_filesize: 300M
  • php_post_max_size: 1000M
  • curl_version: 7.54.0 LibreSSL/2.6.5
  • suhosin: false
  • imagick_availability: true
  • pretty_permalinks: true
  • htaccess_extra_rules: false

Hello @michelyweb,

Sorry you’re having trouble. Thanks for the details.

Have you made sure to make it available in REST?
This is necessary and can be toggled to true in the CPT editor (Show in rest option in REST tab).

1 Like

Oh man, that was an easy fix. Thanks!

1 Like

Glad that helped. Thanks for letting me know!

This happened to me too… BTW this in independent of Cwicly. Its just how Gutenberg loads its data.