Post tag and query builder page maximum limit function missing

Post tag issue: seems the source type miss taxonomy query function

can not add the post tag, function seems missing.

from the old version it should be like this:

once you set(select p, and right click, then wrap with taxonomy terms, function can not work), can not edit any more.

query builder page limit issume:

if i put in 2, it should only list out 2 page maximum, right? ,but it will keep load the first page repeatedly, again and again forever. if i remove the setting here, it will load properly.

my version is Version

ps, just update to Version , same issue as before.

Hello @qiang814k,

To be able to access the Taxonomy Query dynamic source, make sure to set your Query type to Terms.

Also, the page parameter does not work like that, referring to the official documentation:

Number of page for a static front page. Show the posts that would normally show up just on page X of a Static Front Page.

after testing for couple of times, i think the process below will help you to find and fix the bug

Taxonomy terms have bugs when you select source as current for first time.

Taxonomy terms will works very well if i select source as custom for first time.

Hello @qiang814k,

I think there is a mixup here.

The Taxonomy Terms block automatically provides a Taxonomy Terms source for dynamic content blocks.

The Taxonomy Query source that you show here is only available when used in conjunction inside a Query block that is set to a Terms query.

The reason “current” does not apply to the Taxonomy Terms block is because you are in the Site Editor, that doesn’t apply to a specific post. I suggest you use the Dynamic Preview function to be able to use the “current” source.

ok, get it clear now,
thanks so much for your explanation.