Modal block does not appear on edit screen

Modal is not showing up on the edit screen, is there something wrong with my settings?
Also, does the tablet/mobile layout not adjust the size of the edit screen on click only?

Environment info

  • WordPress version: 5.9.3
  • Gutenberg Plugin version: deactivated
  • Cwicly Plugin version: 1.1.0.7
  • Cwicly Theme version: 1.0.3

Hi there.

Apologies for the trouble you’re encountering.

Have you tried toggling the Hide/Show Cwicly Modals option in the editor settings?

As for the tablet/mobile layout not adjusting, I take it you are using the template part editor? In this case, the WordPress/Gutenberg team have decided to unlink the preview change with the functional change. To show the correct screen size, you can simply drag the placeholders on either side of the editor to modify the width, which in turn should change the responsive mode.

There might be is an issue since the last update.
Modal height does not apply the given height inside the builder when the unit is “%”.
Frontend is fine.

Edit: Just have seen you replaced the height with min-height in the newest update (thanks for adding my improvement request).
Since there is no fixed height, a unit of “%” won’t be respected.
This could be solved by just adding height: 0; for example.

Let me know in case you want me to open a new topic for this.
Thanks.

Thanks.
The Modal thing showed up as soon as I set it up.
I also understand about the tablet/mobile layout.:+1:

Regarding the tablet/mobile layout, since the icons are only displayed as if they could be adjusted, it would be helpful to add a note text near the icons or a tooltip stating that clicking is disabled.:thinking:
First time users of Cwicly will think it is a bug.:sweat_smile:

Thanks Marius for picking up on this, as always :wink:

Strangely enough height: 0; was put forward but I’m not quite sure why it didn’t make it to the final version… I’ll have to see why it was removed. Apologies for that!
We’ll get this fixed very soon.

1 Like

Glad that worked out @Takeru.

Indeed, things could be made clearer for the modal and responsive settings on the template part editor.
Since this is a change the Gutenberg team made some time ago, we were hoping to see some consistency between the different editors.
It doesn’t seem to have been a priority for them so we’ll work on an appropriate solution on our side.

Thanks for bringing this up, as it helps us understand what is missing or unclear.

I now understand that there is a hide setting because it is disturbing to see the modal outside of the header parts.
It is nice to know that every detail has been carefully designed.
However, since the modal may be used as a popup, it would be more useful if the block that opens the modal had some kind of prominent design, such as forcing a border of a specified color around the block.
Also, related to the header, it would be more convenient to edit the header while editing other parts rather than directly from the header edit screen, so that the width can be adjusted for tablet and mobile design.

I think that would lead into some confusion regarding the UI.
Personally, I don’t like to have additional indicators on my canvas, because I want to see the result inside the editor directly.
Things like that would be counterproductive.

How about just giving the block inside the Navigator a proper name so you can easily identify it?
In addition, labels for block items inside the navigator has been recently introduced so you can see instantly which element is attatched to an interaction.

I think the implementaion of the template parts inside the editor is really convenient and you have super fast access to all of them.
That behaviour would create more problems than solve, but that’s just my humble opinion.

2 Likes

I think that would lead into some confusion regarding the UI.
Personally, I don’t like to have additional indicators on my canvas, because I want to see the result inside the editor directly.
Things like that would be counterproductive.

I will try to work that way once.
Thank you!