License - Unexpected Error

I’m not sure if this is related to any of the server issues yesterday, but I am getting a “License - Unexpected Error” on the Settings page.

I’m running v1.2.8 and realize there is an update for v1.2.8.1, but I’m not getting the prompt to update, so I’m not sure if that’s also related. I suspect the new version will fix whatever is happening, if I can get the new version. Is there something I’m missing here, or should I just wait longer to see if the update comes through? Also, will bad things happen in the universe and with my install if I delete Cwicly and upload the new version manually? Like will all my settings and styles vanish? Thanks!

You can download and update manually. Everything will be fine. :slight_smile:

1 Like

Hi @msguerra74,

Sorry to hear you’re having trouble with the license check.

Indeed, this error usually means that your installation had trouble reaching out to our server.

Did you try clicking the “Refresh Data” button on the Settings page? If so, did it just reload the page with the same error?

No worries about removing then installing Cwicly. You can also just upload the new version via the Add New plugin and let WordPress do the job for you.

Experiencing the same, independently of the Cwicly version which is installed.
Refreshing the data does not help.

I assumed it is a general problem but seems it’s not?

Thanks for letting me know @Marius.
We’ve seen quite a few automated updates going through on our side, which might suggest a dns issue?

Is this on a local installation?

These are live installations, hosted on Siteground @Louis.
Currently no other installation available to check on a different hosting.

Checked on local as well, no issues there.

If you need access to check out what’s going on, just let me know.

1 Like

I have no issues with the license check on my local installation (last version and version before).

1 Like

Hi @Marius,

Thanks for the details.
I think this might have something to do with DNS updates since we were also hosted with SiteGround for some of our services up until the change a few days ago.
We normally write to the log if there is an error in the request, could you possibly check that out?

Nothing that differs from my local installation @Louis.

1 Like

Really sorry about this.

I’d love to take you up on if still possible :slight_smile:

1 Like

Just sent you the login.
Feel free to install any tool which helps to debug.

Thank you very much @Marius!

1 Like

My sites are also all hosted on SiteGround, so whatever you find on his, will probably be the same for mine. I love SiteGround BTW! Most of mine are staging versions, but I do have a live client site hosted on a completely different SiteGround account (via collaboration) thats also giving the same error and it’s on v1.2.7.2 with no update prompts. The error persists when I click the Refresh option as well.

I don’t have a problem manually updating them, I just wanted to make sure it wouldn’t wipe anything out.

Hi @msguerra74,

Indeed, this is quite urgent and we’re very sorry about the trouble caused here.

Thanks to @Marius’ installation, we’re noticing cURL 28 errors whenever trying to contact our server, which could suggest that SiteGround is blocking the call (for whatever reason).
If possible, could you contact their support to see if there is some type of block on calls for or

1 Like

I managed to update the plugin manually, but now after a few seconds of editing a page, the blocks vanish and give a license error, so nothing gets saved when I save. Are there any workarounds that can be done while we wait to hear back from SG?

I was chatting with SG support and they said: “I have checked the and seems its not blocked on our end so far” and he wasn’t able to see anything in the error logs that looked like it was connected to the IP or Cwicly site. He was also asking where you saw that error you mentioned, but I didn’t know what to tell him about that, so looks like we’ll need more info to figure this out.

Hi @msguerra74,

Really sorry about this unfortunate issue.
Both our host and SiteGround are blaming each other which doesn’t help.

We’re doing an urgent move to another host which should be done within less than 3 hours.

Apologies for the inconvenience!

Yes, it’s not helpful when they do that. I’m good for the moment because I’m done for the day, so we’ll see what happens. Thanks for looking into it and sorry for the hassle. I’m sure it’s stressful for you to have to juggle so much and make sure everything is working everywhere at all times!


Thanks for the kind words @msguerra74.
Everything should be back in order.

Thank you for your patience on this one, thanks @Marius for the access to your installation.

1 Like

Thanks! Seems to be working again. Hopefully you can get working whatever you were trying to get working with the host change.

1 Like

Thanks for all your efforts, Louis.
Very unfortunate situation indeed.

I can confirm that everything is working now again as intended. Well done :clap:

1 Like