How to activate 3rd party theme?

I am probably being extremely stupid here, but I have just activated a 3rd party FSE theme for the first time with cwicly but when I view it on the front end, it is displaying all the content in the cwicly blank theme.

Is there some setting I should know about? Searched the docs and can’t find anything.

Hi @sjpoty,

Please check the Cwicly Themer templates.

You will still need to select any templates and in some cases use Visibility Conditions to apply them to specific pages, archives and single posts for them to appear on the front end.

Hi, @StrangeTech

I’m hugely confused. Cwicly says i works with any theme.

I have a new install, using the Ollie theme which works fine. I then installed Cwicly and the frontend styling disappeared - just a text page. The Ollie theme is active in the backend so it should appear normally. The same happens if I switch to the 2024,2023 theme - no styling.

Is Cwicly disabling something. I can’t find any settings or visibility settings to change.

I opened the themer and all the pages look like no styling. When I click to edit any of them, the Ollie theme styles are there.

There are no visibility settngs - if there are then where are they?

Hi Again,

I’ve just orked through the tutorial - > https://docs.cwicly.com/beginners-guide/create-your-front-page/front-page

Applied and saved one of the templates, but the template isn’t being applied. Repeated this with several templates and still no styling.

Tried with the 2024 them and it doesn’t work either. see here - ollie.slpoty.co.uk

Hi @slpoty,

Please check the visibility conditions for the templates:

I did. Look at the screenshot. Ive applied custom templates, added default templates, tried every combination but there is no styling - this is what you see on the front end. Surely this can’t be right or this difficult.

So, if I understand correctly, your template is being used on the front-end now, but you are not seeing the styling?

What styles are you expecting to see from the Theme and do they appear in the back-end when editing the template?

As with any new tool, there is an initial learning curve. It seems like you are not only learning Cwicly but also gaining more exposure to FSE, which I think is the primary challeng.

What I will say is, we find Cwicly to be extremely easy to use, so it is worth the investment of time getting to know how it works.

Correct. No styling at all. In the backend, you can see the styling.

I’ve tested this on another subdomain with the 2024 theme - no styling front end but styling on the backend template.

See screenshots




Please first check Settings > General and make sure the site url https is consistent in case that is an issue. If that doesn’t resolve it, please check the CSS inspector on the front-end in the browser to see what is being loaded.

I’ve built 10 sites from scratch using the FSE so I know it quite well.

Done all this beforehand. Reset permalinks, flushed cache etc. Nothing unusual. Rebooted the server, flushed redis cache, reoptimised everything possible. and all checks out correctly.

2 anomolies. 1) When creating a custom template, I’m seeing this error “Your site doesnt include support for the cwicly/content block”
2) server logs showing a script error - AH01071: Got error ‘PHP message: PHP Warning: Undefined array key “postId” on line 27’/wp-admin/admin.php?page=cwicly

Ahh I see, I misread your previous statement as you being new to FSE, rather than just new to using a 3rd party FSE theme with Cwicly specifically:

If you haven’t already done so, may be worth uninstalling Cwicly and reinstalling the latest version as there was an issue with blocks not being rendered in WordPress 6.4.1, which was fixed recently. If that doesn’t resolve the issue, perhaps check if any plugin or snippet is causing a conflict.

Thanks. Tried all this and no joy - no plugins, snippets were installed. I have just created 3 clean installs on 3 different servers with only the Cwicly plugin and 2024 theme. Cwicly docs say that it will use the default templates on a new install. I haven’t done anything in these 3 installs and this is what I see on the themer page - layouts broken/unstyled. This is also what I see on the frontend.

This has got me beat so I can only guess that there is a setting missing or part of the docs has something missing or it’s a bug.

Hopefully the devs will look at this and advise. Happy to give server access.

OK - fixed in advanced settings by disabling this.

I would suggest using the Cwicly theme, as it not only provides the best support, but also allows you to do anything you can find in any other theme, but without the headache (as you’ve experienced here). It might be tempting to use all the fancy features built into a 3rd party theme, but I haven’t run into any feature that I couldn’t replicate in Cwicly in a much cleaner and simpler way. You can also save and reuse things you create in the Cwicly cloud library, as well as build and save components that can also be reused, so you don’t have to rebuild things over and over.

These are just my thoughts, though, and I’m glad to see you finally got things working. Either way, you can’t go wrong incorporating Cwicly in whatever way you can!

The headache wasn’t with the theme and there weren’t any “fancy features”. It was a simple block based bare bones FSE theme that I spent 2 days designing. I’m not going to start from scratch using the cwicly theme that isn’t any different to what I started with. I’'ve also spoken with support directly and it’s been confirmed as a bug that it will be fixed.

Oops, alright, sorry about that. I’m glad you got it working though!

1 Like