How can I fix the ACF wysiwyg Field formatting HTML?

Description:

ACF wysiwyg Field is auto formatting HTML, adds < paragraph > tags, which I want to disable but I don’t find any options.

In coding, we used to do this: the_field(‘myfield’, false, false) which automatically turns off the HTML formatting for that specific Wysiwyg editor field.

Step-by-step reproduction instructions:

Please write the steps needed to reproduce the bug.

  1. Open the Post Editor/Site Editor

Screenshots, screen recording, code snippet

Insert Images, Videos or GIFs

Environment info

  • WordPress version: 5.9.3
  • Gutenberg Plugin version: -
  • Cwicly Plugin version: 1.1.4
  • Cwicly Theme version: 1.0.3

Hello @haroonbro,

Thanks for bringing this up!
We currently recommend to change the Paragraph block tag to a <div> so that it doesn’t print the HTML on the frontend, but formatting is an option we will be adding to the dynamic selector very soon.

Cheers,

4 Likes

Amazing. Thank you so much Louis. Appreciate your time to reply my silly questions.

Thanks so much for this. For the longest while I have struggled because it was adding a blank <p> at the beginning of all of my blocks of text. This small edit fixes all of that.

I’m finding that unless I specifically want body text, it’s simply better to tag the paragraph blocks as either <div> or <span> to eliminate any unwanted styling.