Hide Element not working

Hi All,
to not show an NAV element on Desktop i used display:none…but this doesnt work…also to hide it in the editor navigator doesnt work either…do i have to use media queries right now?
best wishes!
timo

Hi @Timo in your browser make certain that the property display:none is applied to your element. If the property is missing, make certain you are doing a hard refresh of the page (clearing the cache on page reload). If the property is indeed missing go to Cwicly > Settings and regenerate Blocks HTML & CSS. Let us know now you get on.

Hi @Timo,

Sorry to hear you’re experiencing trouble with this.

The reason you’re not able to use display:none to hide Nav elements, is that the logic used for the Nav block will override that setting.

To hide, be sure to add this to the Nav element’s Custom CSS tab:

.blockclass {
  display: none !important;
}

/* Tablet */
@media (max-width: 992px) {
  .blockclass {
    display: block !important;
  }
}

Note: I set the Nav element to reappear at the Tablet breakpoint, however it could also be set for mobile which would be:

/* Mobile */
@media (max-width: 576px) {
  .blockclass {
    display: block !important;
  }
}

Kindly let me know if this helps!

1 Like

hi @Araminta ok cool thanx a lot!

1 Like