Google Fonts again (on 404 complete empty page)

Hi all,
i know there are one or two threads already but i can not find any solution…after a loooong journey of trying to avoid loading google fonts i wanted to know it now from the ground…if i setup a 404 page default without ANY content wihtout header, without footer without any template…still google fonts are loaded…
what must i do that the cwicly ground-setup is not loading google fonts?

example: https://confect-service.de/teasdfadfs

best wishes
timo

Hello @Timo,

Cwicly does not enforce any Google font by default.

When looking at your website previously, it suggested you had set up Google fonts in your Global styles.
I don’t see any reference to Google fonts on your page currently.

Cheers,

hi @Louis yes thx a lot i was able to kill it all.but on my other page where header and footer is loaded i am not able to deactivate it…somewhere it must be active right?

its here:
https://confect-service.de/test/

Hello @Timo,

That would be in your header, more specifically your menu block.

Cheers,

ok is see but we dont use roboto there…i saw the “G” was stil blue…so i deactivated it and it still loads…the surrouding DIV also had a blue “G”…but there are not fonts no character, not content…does google font also load when elements are marked with blue “G” also while without any content? i deactaved all google fonts-hosted icons…maybee i missed one? it still loads…
see here:

@Louis This has also been giving me a headache for some time. Do I really have to manually switch off the G for Google fonts in every block? This is very tedious and I have long assumed that all blocks adopt the global font settings, especially as Cwicly is otherwise so well thought out. This should definitely also apply to the choice between local and Google hosted fonts. This is really urgent and should be fixed as soon as possible. It would be important that this also applies to existing pages. Thank you for your otherwise consistently great work!

Hi @msteinlein,

Please see these feature requests:

Hello @msteinlein,

I think there might be a misunderstanding here.

Google fonts are not added until you specifically select and apply one from the selection.
There has never been a need to toggle the Google fonts icon.

In @Timo’s case, it’s within the menu settings themselves.

I will repeat once again: no Google font is added unless explicitly applied by a user.

Cheers,

yes i also thought that but the blug G is auto-activated in some cases…maybee it derives from a cloud pre-theme? i now try to tputt it off…

In both my cwicly installations Google font is by default selected as on (blue g), on every block. Even if I use in my global font settings just local fonts. I’ve never set it to on by myself. It’s the same with every new cwicly block I add. I think other users have the same issue, according to the mentioned feature requests? As always: Thanks for your help! :slight_smile:

Hello @msteinlein and @Timo,

I might not have made myself clear above, my apologies.

The Google fonts selector is toggled on by default.
If no selection has been made for the font family, no Google font is applied.

There is no need to toggle the Google font selector off.

To put it more clearly: how would Cwicly apply a random Google font if no selection has been made by the user…

Cheers,

ok i try to check this :wink:

hmm i dont know where this roboto comes from…i walkted through all again…this is the setting for the menu…also checked global classes and deactivate remaining two…refreshed generated CSS and such…still there…

Hi @Louis, the salient point, as per the feature request I made is - if you don’t use Google Fonts, the user has to toggle the Google font button off every time to see the local fonts listed - this is not ideal for usability and can result in a user accidentally choosing a Google font rather than a local one.

Thank you louis for your answer :slight_smile:
So do I understand the following correctly:
If I have defined local fonts in the global settings


, even if no font is selected for a block, but G is activated

, only the global local font and no Google font is loaded? As soon as I deselect G, inherit is displayed

. I think this is causing confusion.

Hello @Timo,

Please look at the primary tab settings for the menu block. The font seems to be applied to menu items.

@msteinlein, if there is no Google font selected, I’m not sure how confusion can be founded.

Cheers,

Because I would expect inherit as default of a new block. If the g button is toggled on by default and after pressing it inherit appearing, it confuses me as a user. I just don’t understand why the g button is set to on by default. Please don’t get me wrong, after your clarification I understand now that there is nothing loaded before choosing a g font, I just want to explain my confusion with the topic. Thanks again for your fantastic work and brilliant support!

Good Morning Louis,
but in the primary tab there is no font feature…

Hello @Timo,

The dot indicators should guide you.

Cheers,

ah thanx i checked that you where right sorry. i also checked again the footer template and they where two remaining i didnt saw them as if you click on them the link-modal opens up…now i deactivated i hope really all remaining. but still loading google fonts…here:

https://confect-service.de/test/