Error in global class stylesheet

Hi!
I noticed an error in the global CSS stylesheet when I styled my element with a global class.

I tried regenerating the CSS, but it is still there.
image

The class

.main__title

is now

.,.main__title

So the colour doesn’t apply to my heading because of this error.

*P/S: when I create this global class, I didn’t type any symbol. I just typed the class name instead.

  • WordPress version: 6.0.3
  • Gutenberg Plugin version: -
  • Cwicly Plugin version: 1.2.3
  • Cwicly Theme version: 1.0.3

Also, I noticed another bug with the global classes.

Refer to the screencast:

*I can’t speak well. I hope you understand what I was saying. :smiley:

In my opinion, regenerating global CSS should not affect all the CSS properties of the existing classes. So far I didn’t face any issues with the builders I am currently using.

I can confirm that regenerating the global classes will remove global classes from the global stylesheet.
However, it seems this does only happen with new created global classes.

Global classes which were created some time ago are not getting removed when regenerating the global CSS.

Tested with prior version (1.2.2.4) without issues.
So probably introduced with v1.2.3 which welcomes some global style related changes.

1 Like

Hi there @jornes,

Thanks for the detailed report.

Regarding issue #1, I’m not quite sure how this is happening and can’t find a way to reproduce it on my side. If we can have temporary access to your installation, it will take 2 seconds to see what’s going wrong.

For issue #2, may I ask you to try and refresh the settings page before regenerating if you have made changes in between to see if the error reproduces itself?
We haven’t thought of the possibility of a use-case like yours where a user keeps the settings page opened to regenerate in between Global CSS changes, so this might be something to change on our side.

Could you possibly try the solution above? Or are you experiencing this even with a refresh?

1 Like

Seems you are completely right @Louis.
Tried several times, went different routes but without the settings page opened.
No issues faced.

Apparently, when checking on the prior version on another installation I went the straight path so I wasn’t able to reproduce it.
I did the same with my initial testing but somehow must have saved the page again after I directed to the settings page. I am sure it wasn’t open before, neither on another instance.
So all fine now.

Thanks for making things clear, good to know for the future.

1 Like

Thanks for confirming that @Marius :+1:

Definitely something that will be fixed in the next update as this data should be up to date whatever the circumstance.

3 Likes

Hey @Louis
I have just signed in to the site again, and the 2nd issue seems got fixed itself. Anyway, a better solution is necessary because I will sometimes keep the setting page open while doing my site. Because I’m kinda lazy to leave the page(while editing), then head to the setting, then come back to the page again.

Regarding the 1st issue, I can’t fix it. I think I will need your inspection for this.
Where should I send the temp access link to you?

@Marius Thanks for confirming that!

Hi @Louis

I have sent you a message containing the site’s temp access link.
Thanks! :wink: