Custom archive template does not work for CPT when assign tags(wp core) to it

I create a custom post type(slug:company), then assign tags(wp core) to it. see attachment below

then i created a custom archive template for this custom post type, show if tags(wp core) and the other two taxonomy. see capture below

but this template does not work for show if tags(wp core) archive at all. “does not work” means, when i click the link of tag, the archive page does not apply the template

for the other two CPT taxonomy archive, works very well.

i am not sure this is bug or i am doing wrong way.

by the way, i also use Custom Post Type Permalinks plugin,

if i assign this template for default post tag archive, it do works.

so, i think this is a bug problems here need to fix.

summary:
if i assign tags(wp core) to a custom post type,
i can not make a archive template for this custom post type tags(wp core) by cwicly

i do not want to push :rofl:, i know you already working very hard. :smiley: but i am wondering to know, will your guys planning to fix this or not?

Hello @qiang814k,

Sorry for not getting back to you on this one.
I wasn’t able to reproduce it on my side when tested (quickly) last week, this was with CPT UI. I’ll have to take a bit more time on this and see what’s going on.
Apologies for the delay, and it certainly has not gone unnoticed.

thanks, you can use the test site which i send you by email to test(the one start with www2.), if you would like.

Perfect. Will do that.

Hello @qiang814k,

I tried logging in to your website, unfortunately the username/email seems to have been removed.

e, sorry. Louis
since we are moving data to the website, so they recover the content, that is why you can not login
you can test on this site Log In ‹ 创意设计策划平台 — WordPress (i made everything perfect for you to test, may be can save your time)

please use the same login info which i send you before

hello, Louis, just wondering to know , how is going on this topic now,

let me sort the issue more clear(you can check with my demo site if you like)

  1. create any tag for default post type(group its posts in this tag), everything working very well, no problems at all, means, when i click the tag, it will list all the posts as expect.
  2. create any tag for custom post type(group its posts in this tag), does not working at all, means, when i click the tag, it will list none posts as expect.
  3. create any tag for default post type and custom post type (group posts its tag from default post type and custom post type), when i click the tag, it will only list the posts from default post type, none from custom post type

for me , the cwicly archive template only can list out tag posts from default post type. but can not list out tags post from custom post type, it sounds like somewhere missed the post type parameter setting.

sorry, Heroes i am trying to bring this up,
i am wondering to know, is this on the checking or not ?

if this is really did not on cwicly schedule, please let me know(or give me some suggestion will also be appreciate), then i can try to find a programmer to check whether can fix it. (i hope this can be fixed by cwicly team, if so, means this is fixed forever :stuck_out_tongue_winking_eye:), I guess this will not easy for other programmer to check up and fix either, plus plugin updating might be also cause issue in the future.

for my limit knowledge, acf and cpt ui, are two most important plugins for dynamic content, i think other people might also meet this issue in the future either.

plus, this is a complain, i know all your guys are on Tarff working :raised_hands: