Can't select font weight and font manager in editor don't work


I want to change the font weight but there is no list and I have to write down the weight every time I want to change font weight, and when I add a font from the font manager it won’t even change the font, I had to use backend font manager.

and I did nothing to make this problem I just Installed cwicly on a fresh WordPress install and added a font that’s all.

the blue dots are out of place in RTL, it’s fine for now, but if you can please take care of it in the next updates.

Thank you.

Environment info

  • WordPress version: 6.1.1
  • Gutenberg Plugin version: -
  • Cwicly Plugin version:
  • Cwicly Theme version: 1.0.3

Hello @moheb.azartash,

Sorry to hear you’re having trouble with setting the font weight for a font that is added through the new Font Manager.

Can I first of all ask if this is a variable font?
If so, can you possibly check that the font-weight descriptor property is properly set to support a variable font-weight such as: 100 900

Thanks in advance.

Thank you for bringing this up. It will be fixed in the next update.

I tried the variable version first I couldn’t get it to work so I decided to use non-variable versions. still no luck.
when I use backend font manager, the font starts working but still, it’s not a selectable list it’s just an input box.

again today I tried variable and made font-weight 100 900 still nothing. and again using non-variable nothing happened again. The problem is when I add a font in the new font manager nothing uses the font it just uses default system fonts.
but I tried google hosted fonts they work but still, weight is not a selectable list it’s just an input box.

and I disabled xml-rpc I don’t know if that has anything to do with these problems.
and my PHP is 8.1.16.

Second, let me say this I think the cwicly plugin file I downloaded has some problem or something missing cause I don’t even have the black bar under the WordPress logo.

How it should be

How mine is

Hi @moheb.azartash

Could you possibly provide the font file so we can try it out on our end?
Thank you in advance.

As for the Quick Inserter, it isn’t activated by default.
You can enable it from the Global Styles > Settings > Backend tabs (see screenshot).

1 Like

I didn’t know it was an option, Thank you.

I will send it, Thank you.

1 Like

Hi @moheb.azartash,

Thanks for the font file.
I’ve just tested it on my side and all seems good.

If you prefer continuing through support, please let me know.

Could you possibly share with me a screenshot of the font set up in the Font Manager?

Thanks in advance.

I did Setup both Variable and Static fonts.

I have a feeling that I have to say this: I have cwicly installed on 2 sites and I have this problem in both of them. one is in Persian and the other in English. English one I can give access, if you want to try and find out what’s going on with it.

Hi there @moheb.azartash,

I’m definitely not able to reproduce this on my side as font-weights are being correctly applied to blocks.

Is this on a live installation?
If so, could you possibly send us temporary access to so I can take a quick look and see what could be going wrong?

Thanks in advance.

yeah, I send the information.

Great job with cwicly and
Thank you.

As confirmed by yourself in an email exchange with the team, you confirmed that the font weight was properly applying to the variable font. (Variable fonts are not supported in the deprecated font manager → no possibly to input 100 - 900 descriptor values).

As for the font upload issue, this is more specifically related to a server misconfiguration that we will have a fix for in the next update.

Yeah, I confirmed that.

Ok, thanks for the information about fixing it in the next updates. It’s ok for me to use the legacy way of dealing with fonts for now.

Thank you for helping.