Can't delete templates


I just installed version and then tried to delete a page template - instead of being removed from the themer page the template in question just got moved to the end of the list and refuses to be deleted. I tried rolling back my Cwicly version and deleting again but that didn’t work either.

  • WordPress version: 6.1.1
  • Gutenberg Plugin version: - n/a
  • Cwicly Plugin version:
  • Cwicly Theme version: 1.0.3 Child theme

Hi @smontreuil,

Sorry to hear you’re experiencing trouble with this.

Unfortunately I haven’t been able to reproduce this issue on my end.

Could you possibly let me know if this is happening on a multisite installation?
Does this happen with both custom and default templates?
Do any errors appear in your browser console log?

Thank you in advance.

Hey there @Araminta,

  • Yes, this is a multisite installation.

  • I was going to say that I am only trying to delete custom templates but when I look for errors I realize that these templates got created by a site export so that we could transition the site to a child theme and that, in effect, made them default templates.

  • yes, there is an error ‘Templates based on theme files can’t be removed’

which makes sense now in hindsight.

Thanks so much!

1 Like

Hi @smontreuil,

Thank you for letting us know.

As you said, templates that are included in the theme files are considered as default and can’t be removed, simply “reset”.
We’ll try and make this clearer in the next updates.


Yes, I’m sure that a full-fledged developer would get that right off the bat but those of us who bridge the gap between designer and devloper need a little more guidance. Perhaps also on export it might be helpful to make a note in that regard as well?

Maybe something like:

Note, any templates included your Full Site Editing export will become defaults to the theme you have created. You will be able to edit these on your new site but you will not be able to delete them without going into your file infrastructure via ftp.

1 Like