Bug with Accordion


When Using the Accordion with a lot of text there is a weird gap below the page footer. The gap disappears as soon as you expand the Accordion.

You can see an example here:

Step-by-step reproduction instructions:

  1. Create an Accordion with a lot of content.
  2. In closed state check your page. There should be a space below the footer.

Environment info

  • WordPress version: latest
  • Gutenberg Plugin version: -
  • Cwicly Plugin version: latest
  • Cwicly Theme version: latest

I just found out that the gap disappears when the accordion wrapper is “overflow: hidden”.

Hi @Jonas,

Thanks for bringing this up.
This is explained by the fact that the accordion content is set to an absolute position with visibility: hidden, which explains why long content might cause this issue.

overflow:hidden; seems like a good solution here, but does add some constraints to the content.

Hi @Jonas,

Moving this to general as we currently don’t plan to set a default overflow setting for the Accordion block.

Hi @Araminta,

thanks for the update. That’s alright, it’s no big deal anyway :slight_smile:

1 Like

i am struggling with the same kind of issue since yesterday ! i was writing to report a bug when the nice feature of this post editor suggested me that my bug was similar to your post :slight_smile:

thanks to you i can now move on to something else, thank you @Jonas !

1 Like