Broken Link Picker (adds =URL={)

Hey there,

(sorry if this is a duplicate, couldn’t find any other post related to this topic)

I’m picking up that topic from the facebook Group here, I’m facing the same issue. It works on “normal” links, but as soon as I add a Query Parameter the link gets broken. I have the following link:
/shop/?type=vegan which becomes then to /shop?type=vegan=URL=}

Are there any fixes for the mentioned problem yet?

Thanks in Advance

Cheers Wolfgang

We also experienced this after first upgrading to one of the latest Cwicly versions.

Recreating the link fixed it for us.

We assumed it was a side-effect of:

thanks for your reply @StrangeTech , unfortunately for me that didn’t help. I created the link after upgrading to the latest version, just double checked if recreating it maybe helps but unfortunately it still gives the same output! :frowning:


Hello @Wolfgang,

Sorry to hear you’re having trouble with this. did introduce a bug that would introduce this strange formatting only if you went from an internal link to an external link on the same block. should have fixed this:

Can you confirm that you are removing the link using the unlink icon, then adding it again?

Thanks in advance.

Hey @Louis ,

thanks for your fast response, as always! :wink:

Weird thing is that I’ve never had installed on that site.

But yes, I can confirm that unlinking and linking it again works and the link gets rendered as it should.

Maybe it shouldn’t be marked as completed yet since there’s still the problem when adding a new link with a query parameter it adds that string to the URL. So i would have to unlink and link it again every time!

But as a workaround that definitely works for those few links i have to add! :slight_smile:


Hello @Wolfgang,

Thanks for letting me know.

This is strange as I’m unable to replicate this issue with the latest version.
Entering /shop/?type=vegan then pressing enter results in the correct link being displayed on the frontend.

Will look into this.


Hey @Louis,

ok now things are starting to get weird! xD

I think I didn’t hit enter in my try. I’ve just checked it again and it seems to work fine when I hit enter. It also works fine when I only write “/shop?type=vegan”, but it seems to get broken when I write the full URL and then click on the preview underneath (not hitting enter).

Bildschirmfoto 2023-05-29 um 15.05.44

Can you reproduce that behaviour?! :slight_smile:

Thanks in Advance!

1 Like

Hi @Wolfgang,

Thank you for taking the time to test that out!

Indeed, I tried this right after posting here and I did come up with the same issue.
This will be fixed in the next update. My apologies for the trouble!

Hey @Louis ,

glad i could help :smiley:
No worries, this is really not a big deal since I know now what to do! :slight_smile:


Hello @Wolfgang,

My apologies once again for the trouble related to the link wrapper.
This bug should be fixed in

I’d be grateful if you could let me know if you can now apply links by clicking on them.

Thanks in advance, and thanks for taking the time to help us work through this issue.


Hey @Louis ,

sorry for the late response. Yes, everything seems to be working fine again! If I’m facing any similar Issue I will let you know, but for the moment it seems to be working good! :wink:

Thanks for the quick fix!